Product support

Security Advisories

SUMMARY

EDS-G508E, EDS-G512E, and EDS-G516E Series Ethernet Switches Vulnerabilities

  • Version: V1.0
  • Release Date: Nov 20, 2019

One product vulnerability was identified in Moxa’s EDS-G508E, EDS-512E, and EDS-516E Series Ethernet Switches. In response to this, Moxa has developed a related solution to address the vulnerability.

The identified vulnerability type and potential impact is shown below:

Item Vulnerability Type Impact
1 Denial of service by PROFINET DCE-RPC endpoint discovery packets To exploit this vulnerability, the attacker may cause the target device to go out of service.
AFFECTED PRODUCTS AND SOLUTIONS

Affected Products:

The affected products and firmware versions are shown below.

Product Series Affected Versions
EDS-G508E Series
EDS-G512E Series
EDS-G516E Series
Firmware Version 6.0 or lower

 

Solutions:

Moxa has developed appropriate solutions to address the vulnerabilities. The solutions for affected products are shown below.

Product Series Solutions
EDS-G508E Series
EDS-G512E Series
EDS-G516E Series
Please contact Moxa Technical Support for the security patch.

 

Acknowledgment :

We would like to express our appreciation to Yuval Ardon and Matan Dobrushin of Otorio for reporting the vulnerability, working with us to help enhance the security of our products, and helping us provide a better service to our customers.

 

Revision History:

VERSION DESCRIPTION RELEASE DATE
1.0 First Release Nov 20, 2019

Relevant Products

EDS-G508E Series · EDS-G512E Series · EDS-G516E Series ·

  •   Print this page
  • You can manage and share your saved list in My Moxa
Let’s get that fixed

If you are concerned about a potential cybersecurity vulnerability, please contact us and one of technical support staff will get in touch with you.

Report a Vulnerability
Added To Bag