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Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5102-
PBM-PN and Siemens S7-300

1. Introduction

This application note describes how to configure a Moxa MGate gateway as a
PROFINET I/0 device, a Siemens S7-300 PLC as a PROFINET I/O controller, and a
Siemens DT-200M as a PROFIBUS DP slave with eight digital outputs.

2. Applicable products

Product Line Model Name
MGate 5000 series MGate 5102-PBM-PN, MGate 5102-PBM-PN -T

3. System requirements

Description Model / File Name Version

Siemens S7-300 PLC CPU 315-2 PN/DP 3.2.3
Article Number:
6ES7315-2EH14-0ABO

Siemens PLC programming software SIMATIC STEP 7 5.5 + SP2
Siemens modular I/0O station Siemens ET-200M

Moxa PROFIBUS DP master to PROFINET gateway  MGate 5102-PBM-PN 1.0
Software utility to configure Moxa device MGate Manager 1.8

4. System overview

This document will use the MGate 5102-PBM-PN for illustrative purposes in the following
system architecture.

S7-300 Ely
(PROFINET 10-Controller) &=

PROFINET

(PROFINET I0-Device)
Mgate 5102-PBM-PN
(PROFIBUS DP master)

PROFIBUS

ET200M
(PROFIBUS DP slave)
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5. PLC configuration

5.1. Create STEP 7 project

5.1.1. Start SIMATIC Manager and create a new project by selecting File > New.

KJSIMATIC Manager
File PLC View Option: Window Help

MWew Project’ Wizand .. g

Open... Ctl+D

37 Memory Cand
Memorr Card File

4
4

You must assign a name for the project. For this example, enter Demo1l as
the project name.

New Froject x|

Tser projects I Libraries | Multiprojects |

Wame | Storage path

% 37 _Prol CWProgram Files\BiemensStepTieTprofS7_Pro
%S?-3DD_DP_S].&VB CAProgram Filediemens@tep e T poofia - 200,
%ST-BDD_meibusSIave CWProgram Files\BiemensStep 7T profS7- 300,

| | B
Tpe:
IPrcuject 'l
[~ FLitiasy
Storage location (pathy:
IC:\ngIsm Files\iiemensten 77 proj Browss. . |
Covd | _ mp |

P
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5.2. Create a PROFINET I/0 controller
5.2.1. Select Insert > Station > 2 SIMATIC 300 Station to insert a SIMATIC
300 Station (i.e., the Siemens S7-300 PLC).

{/SIMATIC Manager - Demol

File Edit | Ingept PLC  View Ophons Window Help

S tartion 1 STMATIC 400 Station
Eubnet Ll 2 RIMATIC 200 Station
Program b ZEIMATIC H Station
I , 4 BT A TIC.PC Station
7 Block , 5 Other Station
M7 Softyars N 6 ST A TIC 25

T PGPC
samnbal Tahle
Text Lihrarny r
External Somce. ..

Name the SIMATIC 300 Station as PROFINET_IO-Controller and
double-click on it to perform additional configurations.

QS.[I-mT.[C Manager - Demol

£ Fle Edit Insert PLC View Options Window Help

O |8 & | & B2 | s |

R | B |

El% Demol

Hardware

[ Hw Config - [PROFINET_10-Controller (Configuration) — Demo1]

Eﬂ] Station Edit Insert PLC View Options Window Help

=10 x|
=18 |

(D@8 B(&|| = e || kD22

K

Bix

Suchen: I

Profile  [tanderd

% FROFIEUS DF
.32 PROFIBUZ-PA
-3 PROFINET IO
B SIMATIC 200
B-E3 C7

= - CP-300
Ll_l - CPU-300

:I :' PROFINET_I0-Controller

-] Fr-300
D Crateway
- Th-300
| -0 BS-300

§lot | Designation
|

=0 RACK-300

Press F1to get Help.

. -I3 Ral
-2 SM-300
Bl RIMATIC 400

-8 SIMATIC FC Station

-l SIMATIC PC Based Control 300/400

GEST 390-170-0440
L vailable in various lengths
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Drag the Rail item located under SIMATIC 300 > RACK-300 (in the
right-hand hardware catalog panel) to the upper half of the Station window,
as shown below.

[ Hw Config - [PROFINET_10-Controller (Configuration) — Demo1] B[] ]
E“] Station Edit Insert PLC View Options Window Help _Iﬂlil

[DZe% &&= e da @2 % e

ﬂ oix
Suchen: | ]
Brofile | Standerd |
- FROFIBS DP
388 PROFIBUS-PA
%% PROFINET IO
Bl SIMATIC 300
N
:I :' PROFINET _I0-Controller
§lot | Designation
|
- SIMATIC 400
-l SIMATIC PC Based Control 300400
-8, SIMATIC PC Station
BES7 200-17770-0440 £
vailable in varions lengths =
Press F1 to get Help. I [ m 4

You should see an empty grid in the upper half of Station window as shown
below.

@;:HW Config - [PROFINET_I0-Controller {Configuration) -- Demo1] 101 x|
Eﬂ] Station Edit Insert PLC View Options Window Help = ﬁ'ljl

D258 %&|wedaalm=a]2 e

f’ ol
Sochen: I “ﬂ gf!
i Brofile  [Standand =l
4 - PROFIEUS DP
5 53 PROFIENS-FA
[ -8 PROFINET IO
7 Bl SIMATIC 200
7 = |
K —
=0 w
2ot Module Oind by R e e ;
- j (sl er nnber i Q. | EH:I RACE-200
2 =
3 (-0 5M-300
1 -l SIMATIC 400
T [l BIMATIC PC Based Control 200:400
5 -8 BIMATIC PC Station
7
B
]
il GEET 300- 177004 A0 £,
Tl bvailable in various lengths =
Press F1 to get Help, | | cha
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You must add the proper version firmware for the CPU module hardware
model. In the figure below, we use CPU 315-2 PN/DP as an example. Drag
the proper version of the CPU module firmware from the Hardware Catalog
window on the right and drop it into the empty grid in the Station window on
the left.

E{#:HW Config - [PROFINET_IO-Controller (Configuration) -- Demol] _|EI 5'
Eﬂ] Station Edit Insert PLC View Options Window Help =] x|

0228 %5 ee | dalDo| %8 e
fl ol x|

Suchen: I ﬁﬂ ﬁil

Erofils  [Stndend B3|

- CFT 313 TRM |
- CPU 312C
(L CPU 213
-0 CFU 213C
[#-(Z] CFU 313C-3 OF
= (0 CPU 313C-2 PR
_’|_I -3 CPU 314
(23 CPU 214 IFM
[-(Z] CPU 214C-3 DF
- © 0B {10 CPI 314C-2 PHDP
Siot| [§ Module Crder number v |1 |a -] CFU 514C-3 Pip
i -3 CPU 315
(L CPU 2152 DF
= CPU 215-2 FH/DP
(L3 6ES7 315-2EG10-04E0
SES7 315-2EH13-04B0
2 BES7 315-2EH14-0AB0
;[

1 — =l
GER7 315-2EH14-0AR0 a| £y
384 EB work memory; 0.05ms1000 instmctions; =
FROFINET connection; 87 Commumicatinn

(nadable FBs/PCs); FROFINET [0-Controller; LI

Insertion possible [ [ Cha

] e | AT 00| =] G| | [ e B3

==

Although you will be prompted to enter the IP address for the CPU module,
keep the following default settings.

IP address: 192.168.0.1

Subnet mask: 255.255.255.0

x

Genersl  Parameters |

If & subnet is selected,
the next available addresses are suggested.

Gateway

IP address: 152.168.0.1
2 address = ' Do not use router

Subnet mask: |255.255.255.D
" Use router
[ Use different method to obtain IP address Address: l—

Subnet:

New...

Froperties... |
Delete |

Corce ||
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Click the New button to create a PROFIN

ET network. Keep the default name:

Ethernet(1).
Properties - New subnet Industrial Ethernet x|
General |
Name: Ethemet (1)
57 subnet 1D: II}I}SE - IDDDE
Project path: I
Storage location
of the project: IC:\Users\lEy_men\Desldop\H 02+Dema
Author: I
Date created: 05/28/2013 02:40:27 PM
Last modified: 05/28/2013 02:40:27 PM
Comment: ;I
Crcel | __teo |

Click the OK button. Ethernet(1) should appear as a new item in the

Subnet list box.

Properties - Ethernet interface PN-IO (RD/52.2)

the next available addresses are suggested.

X

Genersl  Parameters |
If a subnet is selected,
IP address: 192.168.0.1 Gateway
@ Do not use router
Subnet mask: |255.255 2550

™ Use router
™ Use different method to obtain IP address

Address: I

Subnet:

— not networked —

Properties... |
Delete |

0K |

Cancel | Hep |
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Page 7 of 20




Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5102-
PBM-PN and Siemens S7-300

Click the OK button to create the Ethernet(1): PROFINET-IO-System
(100) network.

rIJ; HW Config - [PROFINET_IO-Controller (Configuration) -- Demo1] o |EI|1|
Eﬂ] Station Edit Insert PLC \View Options Window Help =1

D@2 5 & e ek B %

_ i olx]
Suchen: I ﬁﬂ gfl
Pofile [Swnded |

-] CPUS2IFM  «|
{00 CPU 313C

[0 CPU 312

{00 CPU 313C

{20 CPU 313C-2 0P
{20 CPUT 313C-2 PP
{20 CPU 314

[-{20 CPU 314 [FM

{20 CPU 314C-2 0P

4u=| @ TR -] CPU 314C-2 FN/D;
Slot FModule Order number Fi |M_ [T Q Comiment D CPU S14C-2 PP

T " --{:l CPU 315

2 [[E] CPU 315-2 PN/DP 6ES7 315-2EH14-0AV3 2(2 D CRU 2152 DF

Xt WPTTF > (2047 =0 CPU 315-2 FNDE

Az A 204857

AZA [ FortS 20457

AN A2 2044

3

g r

5

7 BEST 215-2EH14-04B0 - ?.<|

384 KB work memorny; =

7 0.05ms/1000 instroctions;

o LI FROFINET connection; &7 LI

Press F1 to get Help. [ [ Cha 4

5.3. Create a PROFINET I/0 device
5.3.1. Before adding the MGate 5102-PBM-PN as a PROFINET I/O device, you must
first install the GSD file.

5.3.2. Select Options > Install GSD File...

[ Hw Config - [PROFINET_I0-Controller (Configuration) -- Demo1]
E“] Station Edit Insert PLC View | Options Window Help

J 0= 2 =) | & || E Customize... Ctrl+Alt+E |-

Specify Module, , .
Configure Network
Symbol Table Ctrl+alt+T
2 CPUO 315-2 EN/D  Report Svstem Error,
A MERDP )
e BETS Edit Catalog Profile by
LEE Foit | s
AEFIR Fout 2
3
A
Find in Service & Support...
1] | Create GE0 file For I-Device.. .,
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5.3.3. When the Install GSD Files window opens, click the Browse..

select the proper GSD file to install.
]

Install G0 Files:

|C:\PROGRP,M FILES'GIEMENSE TEF T TP |

File | Release | Version | Lenguages |

Tnztall I Show Log selent A11 Dezelent A1

Cloz Help |

. button to

5.3.4. Select V2.3 and click Install. If the Step 7 configuration software version is

older than 5.4, it may only support GSD files with version 2.2.

x
Install G20 Files: Ifmm the divectory LI
|G:NGaheSlDE_GSD‘PROF[NET GEDML Browse ... |

| Release | Version | Langnages |
GEDML-V2.2-Moxa-MGrate-201301150m] ~ 01/15/2013 12:.0000 &M Y22 English
(3EDML- T2 3-Moxa-MGate-201301150n] 01152015 12:00:00 Ak W22

Install I Show Log Select A1l Deselect A11

Cloz Help |
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Page 9 of 20




Moxa Tech Note PROFIBUS Configuration for Moxa MGate 5102-
PBM-PN and Siemens S7-300

5.3.5. After installing the GSD file, locate the Moxa PROFINET Device under
PROFINET IO - Additional Field Devices > Gateway -> MGate

Generic.
[ HW Config - [PROFINET_I0-Controller (Configuration) - Demoi] =10 x|
Eﬂ] Station Edit Insert PLC Wiew Options Window Help =1
05" & 5 be a2 8
T TR ﬂ il
—ll = Bnchen: | n:l: gr!l
2 CPU 315-2 PN/DP Pinfils |Siandard =
A MERDP ) —
v B0 Ethemet(l): FROFINET-I0-Evstemn (100) g‘!l FROFIEUS DF
AZPIR Fort J B2 PROFIBUSPA
AZRR Fort 2 El’ﬁl PROFINET IO
3 J EID Additional Field Devices
A ~ (L Gratewayr
[
E —— ;IJ
-0 Gateway
:I:l ) ud - HMI
Slot Maduls P ER e e =10
1 = [0 Network Components
2 |[E crU 3152 PH/DP 6ES7 315-2EH14-04¥3.22 =8 Sen.&:u? .
X MEDF 7 |z -0 Switching devices
x B0 B - SIMATIC 300
oA Foes 2045 [ SIMATIC 400
A ez B [ SIMATIC PC Baged Control 300/400
7| - 08 SIMATIC PC Station
I
5
(M rate-PNIO a| £e
& bowa Inc j =
7 El (Moxa Gatewsay) FROFINET
a TOPROFIBUS-DE Gateway Device LI
Press F1 to get Help. [ [ chg 4

5.3.6. Drag the Moxa PROFINET Device to the Ethernet(1):
PROFINET-IO-System (100) network:

Eﬁ' HW Config - [PROFINET_IO-Controller {Configuration) -- Demo1] =] 3
Eﬂ] Station Edit Insert PLC \View Options Window Help _Iﬁllﬁl
[D@e-® %S| 0| dd DD %2
ﬂ olxl
Suchen: I n:l: gr!
2 CPU 315-2 PN/DP Profils |Smndard =
Al MFEDF _ a
x T3] Ethernet(]): PROFINET-I0-Sxystern (1003 FROFIEUS DF
AZFIR Fort f A% PROFIBUS-PA
AR FortZ = ’ﬁ'ﬁl PROFINET IO
3 LI B+ Additions] Field Devices
3 E-D_ CGrateway
= £ Mtate Generic
Pl I I LI_I E Moxa FROFINET Device
-1 Network Components
-0 Gateway
| ) mete-dey 5 HMI
Blot M.| Order number Toddress | O address Diagnostic address: Cormment =0 1o
d meaflMGate-PNTO 20427 = []--g gelwurk Components
x [[] A 204/% e
= -] Switching devices
AV ] Fortf 2048 b
ArAl] Foez B -l SIMATIC 300
T | F-El] SIMATIC 400
7 (-l SIMATIC PC Based Control 300400
3 108, SIMATIC PC Station
1
5
3 b Chate-PHIO . T.<|
oxa Ine. —
7 | ||tom Gaua) FROFINET
o had IOPROFIBUSE-DE Gateway Device LI
Insertion possible [ [ chg 4
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5.3.7. Double-click on the MGate 5102-PBM-PN icon to open the Property

window. Change the Device name to MGate5102, which should be the
same name used to configure the MGate 5102-PBM-MN through MGate
Manager at Step 6.2.3:

x
General |
Short description: mgate-dev
’(M Gateway) PROFINET 10/PROFIBUS-DP Gateway Device d
Order No./ fimmware: MGate-PNIO / V1.0
Family: MGate Generic
Device name: MGate5102
GSD file: GSDMLV2.3-Moxa-MGate-201301152ml
Lhange Felease Mumber... |

~Node in PROFINET 10 System

Device number: |1 =l |PROFINET-I0-System (100)

IP address: 192.168.0.2 Ethemet ..

¥ Assign IP address via |0 controller

Comment:

=l
=
e | Help

Create I/0 modules
5.4.1. Next, you will need to add the I/O module that is connected to the PROFIBUS

side of the MGate 5102-PBM-MN. Since we are using a Siemens ET 200M with
8 digital outputs, you should add one byte of DO output to the Moxa
PROFINET device.

Copyright © 2013 Moxa Inc. Page 11 of 20
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5.4.2. Open the Moxa PROFINET device. Locate the Output 001 Byte module and

then add it to the appropriate slot.

E{,}: HW Config - [PROFINET_IO-Controller (Configuration) -- Demol] - Dlﬂ
En]stahon Edit Insert PLC View Options Window Help - ﬂlﬂ

02" &&= e ddalBe |2k

f’ =1
F CFU 315-2 FN/DP Brofile [Shandesd =l
X7 MFLDF -
xz ) Ethernet(l): PROFINET-10-Bystern (100) =g Mows PROFINET Dev
AZFIR Fort =
ZER FoetZ & () Mok =T Output modules
3 [ WY
El LI ' ” =
-~ |§ COutput 003 By
7 -~ @ Cutput 004 By
—I—I - |§ COutput 005 By
-~ [ Coutput 006 By
ﬂ !l (1) M3a5102 [ Outpnton? By
3ot M.| Odernumber | Taddress | Qaddess | D address: Comment | (4 Ouiput 005 By
0 | g MGalMGate-PIIO 2% =] g““’“t g?g gy
el e EEe J ozgztnu Bi
X ] Aot 2040°
it Ot 012 By
Output 013 By
Cutput 014 By
3 Output 015 By
Cutout 016 By
; 1 i ﬂ_l
£ hdama Ine £,
(Cutput 001 Byrte —
7 | |[osDMLY2E Mo G201 501 L5l
k)
Press F1 to get Help. [ I Cha

After adding the I/O module, you should see the following configuration:

[ HW Config - [PROFINET_IO-Controller (Configuration) -- Demoi] 1ol
@) staton Edit Insert PLC View Options Window Help =] x|
D22 %58 |(edaa bo|B)e
ﬂ ol x|
— Suchen: I ﬁ:l; ﬁil’
] CFU 315-2 PH/DP Ecfile [Seanderd =
AT METDF ~
I s Ethemnat(l): PROFINET-I0-3ystem (100) T & Mo PROFINET Davia]
XIFIR Fort M EHED Tnput modules
R ot 2 B () MOate =23 Output modules J
E -~ |§ Cuiput 001 By,
7 | ' Clutput 002 By
= -~ |d Cuiput 003 By
5 _’l_l Cutput 004 By
—I—I -~ |d Cutput 005 By
Cutput 006 By
ﬂ:l (1) MGae5102 [ Cugmt0n? By
Shot Module Cidex ummber Taddress | Q addmess Diagnos... | Com.. | gutput ggg gy
7 MGate5i02 | MGate-PNIO 20427 =] Output s By
X D ER J O“g“: IR
- ] Outpu Y
xp [ Pt Outpt 12 By
—_———e,........ . [ Ount013By
|1 [[ Ostput01 Byte I Outpmt 014 By
- (@ Coutput 015 By
Ot 016 By T
: < [ ﬂ_l
3 Moxa Ine £
Crutput 001 Biyte 2
7 < 33DBL-T2.3 Mo Mate- 201 30115 30l
o
Press F1 to get Help. [ I 4
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5.4.3. Select Station > Save and Compile to save the new settings.

FUl HW Config - [PROFINET_IO-Controller {Configuration) — Del

E“] Station Edit Insert PLC View Options Window Help
Mew... Cirl+M =
L =
J_ Open... Cirl+0 i | %‘& |
E Open OMLIME
Close

ve and Compile

_ Emet(
Properties...

Import...
Export...

5.4.4. Select PLC > Download to download all the settings onto the Siemens
S7-300.

I'IJ-,_'{: HW Config - [PROFINET_IO-Controller (Configuration) -- Demo1]
@l station Edit Inser ' ' 2

D= g8 By

Dawnload Module Idemtification. ..
|Uplaad Madule Identification ta P&,

Faulky Modules. ..

IMadule Informatian, . . CEr| 0
Cperating Mode,., Chrl+I
ClearfReset. .,

Z Set Time of Da. .
IMamitor Modify:
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6. Moxa’'s PROFIBUS device configuration

6.1. Install the GSD file

Before configuring the Moxa MGate 5102-PBM-PN, install the GSD file for the
PROFIBUS slave device so the MGate 5102-PBM-PN can recognize the device.
6.1.1. Execute MGate Manager and click the GSD Management button to install

the GSD file.

Device Identification Device Function

= || |
I

Search Configuration

Locate Load Default

Language G50 Management

Click the Add button to locate the GSD file.

Mame | Vendor | Filename

2

X

QK |

Copyright © 2013 Moxa Inc.
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Select the GSD file and click Open to install it.

(@open x|
OO | .~ Computer - TI30847100A (C:) ~ ET200M = m” Search ET200M D]
Organize ~  MNew folder == - [ @
- Favorites = i S |
B Desktop B s03801e.05e GSE File
& Dovnloads || sin3801e.qsf 2/25/2008 1:03AM  GSF File
i Recent Places | | sin3801e.05g 2/25/2008 :03AM  GSG File
=5 Lirarkes || si03801e.qsi 2/252009 1:03AM  GSIFile
| Documents | |sin3snie.gss 2/25(2009 :03AM  GS5File
J‘P Music
=] Pictures
B2 videos
1% Computer
£, 1308471004 (C2)
s Transcend (D)
5 TS (\\moxa.com'mt
1l | 5
File name: Isi03801e.gse j
Open |v| Cancel |
A4
6.2. Device configuration with MGate Manager
6.2.1. Start MGate Manager and Search for the Moxa MGate 5102-PBM-PN
gateway.
Mo, | Mame | Model | MAC Address

Device Identification

Locate |

6.2.2. Select the gateway and click Configuration to configure settings.

Device Function

Configuration

Load Default

=101 x|

Ver.1.1Build 1

Device Identification

Search | Configuration Manitor | Brocor Mapping | Import |
Locate | Load Default | Diagnose | Upgrade Firmware | Export |
Language G5D Management | Offine Configuration

Copyright © 2013 Moxa Inc.
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6.2.3. Select the PROFINET tab to configure the Device Name with the same
name used in Step 5.3.7.

|
oK
E = / ;I
. I T
i | T | PROFINET

MGate 5102-PBM-PN

PROFIBUS

‘;) \(x_ I-. -‘|-I

Basic | Network PROFINET |PROFIBUS | System |

Device name IMGateSlDZ I

6.2.4. Select the PROFIBUS tab and click PROFIBUS Settings to start PROFIBUS
configuration.

zl
x|
= ]
Modbus/TCP CELI
BM-MN
'l
(’_ l l‘ PROFIBUS
» © U

Basic | Network PROFIBUS IModbus | system |

address [ Type [ Name [ vendor |
1 Master  Maoxa PROFIBUS Master Moxa Inc.
[ e |
PROFIBUS Settings

Copyright © 2013 Moxa Inc. Page 16 of 20
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6.2.5. Since the GSD file for the Siemens ET 200M was already installed, you can
retrieve it from PROFIBUS DP > I/0 -> SIEMENS - ET 200M (IM153-1)
DPV1.

PROFIBUS Settings

File Edit PROFIBUS

< m) QU5Y

=- ] PROFIBUS DF
=3 10 (1)Moxa PROFII

ET 200M (IM153-1) DPV1

D Gateway

6.2.6. Drag the ET 200M icon to the right window to add it to the PROFIBUS
network:

*PROFIBUS Settings
File Edit PROFIBUS

<) | QU155

=- |} PROFIEUS DP

EI[:I 1jo (1)Moxa PROFT
. =0 SEMENS
n ET 200M (IM153-1) DPV1
D Controllers
-2 Gateway
(12)ET 200M (Ir

Copyright © 2013 Moxa Inc. Page 17 of 20
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PBM-PN and Siemens S7-300

6.2.7. Then select the ET 200M icon and add the following modules:

6.2.8.

Config for Slotl (need to be added for ET 200M)
Config for Slot2 (need to be added for ET 200M)
Config for Slot3 (need to be added for ET 200M)
6ES7 322-1BF01-0AA0 8DO (The DO module we using in this example)

*PROFIBUS Settings =] 3]
Fie Edit PROFIBUS

SHE )

-[E BEST 321-1CFO0-0A | -
[F BES7 321-1FF0=-0A (D)Maxa PROFII

[ 6EST 321-1FF17-0A

[ BES7 321-1BHD=-0A -1

[ 6EST 321-1BHB=-0A .

[ 6EST 321-1EH0=-0A

- 6EST7 321-1BH5"-0A (12)ET 200M (@
[ 6ES7 321-1FF00-0A
- 6ES7 321-1FF01-0A
- 6ES7 321-1BHO0-0A
- 6ES7 321-1BH*1-0A

[ 6ES7 321-1FH00-0A
[ 6ES7 321-1FHO1-0A =l
[ 6ES7 321-1BHS0-0A
JF 6ES7 321-1CH20-08 e
[ 6ES7 321-1CHB0-0A Module
[ 6ES7 321-1CHO™-0A 0x04,0%00,0x00,0xAD,0xC4  Config for Slot1
~[E 6E57 321-7BH00-0A 0x04,0x%00,0x00,0x8B,0x41  Config for Slot2
~[E BES7 321-7BHEO0-DA 0x04,0%00,0x00,0%6F,0xC0 Canfig for Slot3

E :Eg; :i"itggﬂ:' 0x83,0%00,0x00,0%AF,0xC8  6ES7 322-1BFO1-0AAD ... 0

B £ooT 277 chnon e

Then click File > Save, File > Exit to save the PROFIBUS settings.

Return to the main window and click the OK button to save all the recent
modifications and the MGate 5102-PBM-PN will reboot for the changes to
take effect.

x|
= Cancel
Modbus/TCP
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7. Communication Test

7.1. Monitor / Modify Test
7.1.1. Refer to Step 5.4.2 to configure the I/O modules for the MGate
5102-PBM-PN.

:| :| () Mcae5102

I d  Module Cipder number T address 7 addres Diagnos... | Com...
B MGates {02 MGate-PNIC 20427 -
o ([ Ao 2046F
XL Ff !E Fort! 20407 —

[ Homumee [ | |
1 1

7.1.2. Right-click on the Output 001 Byte module and select Monitor / Modify
from the drop-down menu.

Copy Ctrl+C
Paste el
Replace Object...

Add Masker System

Disconmect Master Syvstem

[aster System Isochronous Mode
Inserk PREEINET IS Sy stem
Disconmect PROFIMET IC System
PREEINET LE Damain Management. ...
FROFINET IO Topalaay...

PROFINET 1o Isachronaus mode

Specity Module,..

Delete Del

Object Properties. .. Alt+Return

open Ohbjeck With,.. Chr-AlE+0
hange Access L
Assign AssetID...

Product Support Information Ctrl+F2

FAQs Ctrl+F7

Find Manual Cirl+F6

Stark Device Tadl
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7.1.3. On the Monitor / Modify properties sheet, enter a value for the Modify
Value field to see if the change is indicated by the ET 200M DO module:

x|
Cinline win assigned CPIT services
Bath: |Demnl\PROFINE T_10-ControlleCPIT 215-2 PN/DP
1-; Addwess | Byrabol Drisplay forrnat| Status walue | Modify walue
1 FUb 2o6) HEX GO

—Eun conditionally
[~ Monitor
[~ Modify

% Trigzer

Eun tmmediately

7 Row Not Effective | Update Force Symbol with FS

G} Status Valne I~ Enable Peripheral Outputs
w2 Modify Faloe ™ L0 Display

S TOPPED

Cloz

Help

SIEMENS

SFI7 _ ! DOBxOC2AVIZA 2
L

-

SIMATIC
ET 200M
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