MX-AOPC UA Logger User’s Manual

The software described in this manual is furnished under a license agreement and may be used only in accordance with the terms of that agreement.

Copyright Notice
© 2018 Moxa Inc. All rights reserved.

Trademarks
The MOXA logo is a registered trademark of Moxa Inc.
All other trademarks or registered marks in this manual belong to their respective manufacturers.

Disclaimer
Information in this document is subject to change without notice and does not represent a commitment on the part of Moxa.

Moxa provides this document as is, without warranty of any kind, either expressed or implied, including, but not limited to, its particular purpose. Moxa reserves the right to make improvements and/or changes to this manual, or to the products and/or the programs described in this manual, at any time.

Information provided in this manual is intended to be accurate and reliable. However, Moxa assumes no responsibility for its use, or for any infringements on the rights of third parties that may result from its use.

This product might include unintentional technical or typographical errors. Changes are periodically made to the information herein to correct such errors, and these changes are incorporated into new editions of the publication.

Technical Support Contact Information

Moxa Americas
Toll-free: 1-888-669-2872
Tel: +1-714-528-6777
Fax: +1-714-528-6778

Moxa Europe
Tel: +49-89-3 70 03 99-0
Fax: +49-89-3 70 03 99-99

Moxa India
Tel: +91-80-4172-9088
Fax: +91-80-4132-1045

Moxa China (Shanghai office)
Toll-free: 800-820-5036
Tel: +86-21-5258-9955
Fax: +86-21-5258-5505

Moxa Asia-Pacific
Tel: +886-2-8919-1230
Fax: +886-2-8919-1231

www.moxa.com/support
Table of Contents

1. Introduction ........................................................................................................................................ 1-1
   Overview ................................................................................................................................. 1-2
   System Requirements ............................................................................................................... 1-2
   Specifications .......................................................................................................................... 1-3

2. Getting Started ................................................................................................................................. 2-1
   Designing the System Architecture ............................................................................................ 2-2
   Installing the MX-AOPC UA Logger .......................................................................................... 2-4
   Opening the Configuration Console .......................................................................................... 2-4
   Configuring the MX-AOPC UA Logger Settings ......................................................................... 2-5
   Connecting to the MX-AOPC UA Server ..................................................................................... 2-9
     Getting the Server Endpoint from the MX-AOPC UA Server ...................................................... 2-9
     Connecting to MX-AOPC UA Servers ..................................................................................... 2-9
   Creating Loggers ......................................................................................................................... 2-13
   Starting Runtime Service ............................................................................................................ 2-16
   Starting Recording ...................................................................................................................... 2-18
   Testing the Data Supplement Function ....................................................................................... 2-19
   Testing the Data Supplement on Demand Function .................................................................. 2-24
   Testing the Data Supplement on Schedule Function ................................................................ 2-27

3. Configuration Console ..................................................................................................................... 3-1
   Main Screen Overview ............................................................................................................... 3-2
   Menu Items .................................................................................................................................. 3-3
     File .......................................................................................................................................... 3-3
     Server ...................................................................................................................................... 3-4
     Logger ...................................................................................................................................... 3-5
     Tools ........................................................................................................................................ 3-6
     Runtime .................................................................................................................................. 3-11
     Help ....................................................................................................................................... 3-11

4. Server Management ........................................................................................................................... 4-1
   Server Discovery ......................................................................................................................... 4-2
     Getting the Server Endpoint from an MX-AOPC UA Server .................................................... 4-2
     Discovering MX-AOPC UA Servers ......................................................................................... 4-3
   Server Connection ...................................................................................................................... 4-5
     Connecting to the discovered MX-AOPC UA Server ................................................................. 4-5
     Editing the connection settings of the discovered MX-AOPC UA Server .................................. 4-6
     Deleting the connection settings of the discovered MX-AOPC UA Server ................................. 4-7

5. Logger Management .......................................................................................................................... 5-1
   Logger Group ................................................................................................................................. 5-2
     Adding a Logger Group to a Logger Group List ........................................................................ 5-2
     Editing a Logger Group .............................................................................................................. 5-3
     Deleting a Logger Group ............................................................................................................ 5-3
   Loggers ....................................................................................................................................... 5-4
     Adding a Logger to a Tag Group ............................................................................................... 5-4
     Editing a Logger ...................................................................................................................... 5-7
     Deleting a Logger .................................................................................................................... 5-8
   Logger Recording .......................................................................................................................... 5-9
     Select Tags for Recording ........................................................................................................ 5-9
     Start or Stop Recording .......................................................................................................... 5-11
     Logger Status ............................................................................................................................ 5-14

6. License Registration and Activation .................................................................................................. 6-1
   A. System Performance Reference .................................................................................................. A-1
   B. Database Connection Settings .................................................................................................. B-1
The following topics are covered in this chapter:

- Overview
- System Requirements
- Specifications
Overview

With most remote data acquisition systems, during daily operations additional human resources are needed to collect data manually from remote storage devices for loading into a database. Even with remote I/O devices remotely collecting data over a network, software must be developed to handle the task of converting and uploading data logs. Moxa’s MX-AOPC UA Logger not only makes real-time data collection much easier, it also simplifies the conversion of historical data into database-ready formats. Moxa’s MX-AOPC UA Logger interacts directly with our MX-AOPC UA Server, working as a bridge between field data and cloud storage, as well as stored databases or spreadsheets. The MX-AOPC UA Logger can collate tags from individual Moxa remote I/O devices into the same cloud, database, or spreadsheet, freeing users from the need to manipulate data after processing.

One of the benefits of using remote I/O devices is that data can be collected over a network from a central site. In an ideal operation, after a network failure remote I/O devices should be able to transmit data logs that were collected while the network was offline. Moxa’s MX-AOPC UA Logger makes this not only possible, but easy. MX-AOPC UA Loggers provide a standard OPC interface that interacts with MX-AOPC UA Servers for real-time data collection. After each network connection, an MX-AOPC UA Logger will compare historical data stored on the microSD cards located in individual ioLogik 2500 devices with the real time data it has already stored locally, and then supplement any missing data by requesting that the ioLogik 2500 retransmit the lost data. Furthermore, MX-AOPC UA Logger also supports functions for providing data on schedule and on demand. It will automatically retrieve the lost data when the on-schedule or on-demand function is triggered.

The MX-AOPC UA Logger includes:

- **Logger Runtime Service**: Starts as a service by default after installation.
- **Configuration Console**: A configuration tool for configuring settings.

System Requirements

**Hardware Requirements**

- **CPU**: Intel Pentium 4 or above
- **RAM**: 512 MB (1024 MB recommended)
- **Communication Interface**: Ethernet

**Software Requirements**

- **Microsoft .NET Framework**: v3.5 Service Pack 1
- **Editor (optional)**: Microsoft Office 2003 (Access or Excel) or later
- **Database (optional)**: Oracle database (x86), Microsoft SQL Server (x86), MySQL (x86)
- **Cloud (optional)**: Microsoft Azure
Specifications

**OPC Specifications**

OPC Unified Architecture: 1.02

**Products that Support Data Supplement Auto Mode, on Schedule, and on Demand**

Model Names: ioLogik 2500 series

Note: Please check Moxa’s website for the most up-to-date list of supported products.

**Fully Supported OPC UA Client Profiles**

- Core Client Facet
- User Token: User Name Password Client Facet
- User Token: X509 Certificate Client Facet
- Security Policy: Basic128Rsa15
- Security Policy: None
- Data Access Client Facet
- UA-TCP UA-SC UA Binary
- Attribute Write Client Facet
- Data Change Subscriber Client Facet
The following topics are covered in this chapter:

- Designing the System Architecture
- Installing the MX-AOPC UA Logger
- Opening the Configuration Console
- Configuring the MX-AOPC UA Logger Settings
- Connecting to the MX-AOPC UA Server
  - Getting the Server Endpoint from the MX-AOPC UA Server
  - Connecting to MX-AOPC UA Servers
- Creating Loggers
- Starting Runtime Service
- Starting Recording
- Testing the Data Supplement Function
- Testing the Data Supplement on Demand Function
- Testing the Data Supplement on Schedule Function
Designing the System Architecture

The MX-AOPC UA Logger provides two main functions.

- Storing real-time data collected through an MX-AOPC UA Server from individual I/O devices to a database or spreadsheet.
- Retrieving buffered data stored on a microSD card located in a Moxa device that supports data buffering, such as the Moxa ioLogik 2500 series, and then supplementing the database or spreadsheet with missing data.

We recommend using one of the following two scenarios when designing the system architecture:

**Scenario 1: Write real-time data to a database, spreadsheet, or Azure Cloud**

- MX-AOPC UA Logger saves data from selected OPC tags to a database, spreadsheet, or Azure Cloud. The data comes from MX-AOPC UA Server only, which collects data from field devices.
- MX-AOPC UA Server, MX-AOPC UA Logger, and Database can be installed either on the same computer or on different computers. We strongly recommend installing MX-AOPC UA Logger and Database on the same computer.

**Scenario 2: Collect real-time data while the network is up and running, and retrieve buffered data stored in Moxa devices when the network is disconnected**

- Refer to Scenario 1 for real-time data collection.
- When network communication is reestablished, the MX-AOPC UA Logger automatically retrieves buffered data saved on microSD cards installed in Moxa’s devices when the network was disconnected.
- After retrieving data from the data logs, the MX-AOPC UA Logger automatically saves the data to the database or spreadsheet.
- The MX-AOPC UA Logger supplements data only for OPC tags, which are selected both in the AOPC function of the Moxa device with the IOxpress utility (AOPC → Tag Selection), and in the Logger settings of the MX-AOPC UA Logger with its configuration console.
- For this scenario, microSD cards must be installed in your Moxa devices.
- The MX-AOPC UA Logger’s data supplement function must be enabled (the default), which can be done with the configuration console under Tools → Data Supplement Settings.
• If the IP address of the Moxa cellular device is private or dynamic, Cellular Data Access software must be used to enable the MX-AOPC UA Logger to access Moxa cellular devices. We recommend installing the Cellular Data Access software and MX-AOPC UA Server on the same computer. Use Moxa’s IOxpress utility to enable the Cellular Data Access function on the Moxa cellular device at Network → Cellular → Cellular Data Access. Use the MX-AOPC UA Logger’s configuration console at Tools → Data Supplement Settings.

**When the Moxa cellular device uses a static IP**

**When the Moxa cellular device uses a private or dynamic IP**
The following software can be downloaded from Moxa’s website at www.moxa.com:

- MX-AOPC UA Logger v2.0 or later
- MX-AOPC UA Server v2.0 or later
- Cellular Data Access v1.2 or later
- IOxpress utility v2.1 or later
- Moxa device firmware that supports the data supplement function:
  - ioLogik 2500 series
    - ioLogik 2500-Ethernet v2.2 or later
    - ioLogik 2500-HSPA v2.2 or later
    - ioLogik 2500-WL1 v2.2 or later

Refer to the MX-AOPC UA Server User’s Manual for instructions on how to install and configure Moxa’s MX-AOPC UA Server software.

Refer to your Moxa device’s user’s manual for instructions on installing IOxpress and Cellular Data Access on a computer, and for updating your Moxa device’s firmware.

**Installing the MX-AOPC UA Logger**

The MX-AOPC UA Logger can be downloaded from Moxa’s website at www.moxa.com.

After downloading the file, unzip it and run **setup.exe**. The installation program will guide you through the MX-AOPC UA Logger installation process.

**NOTE**
Microsoft .NET Framework v3.5 Service Pack 1 is required before installing MX-AOPC UA Logger. After the .NET Framework is installed, restart your computer and run setup.exe again to install MX-AOPC UA Logger.

**Opening the Configuration Console**

Open the MX-AOPC UA Logger’s configuration console from the Windows Start menu: **Start → All Programs → MOXA → IO Server → MX-AOPC UA Suite → MX-AOPC UA Logger**.

Select the appropriate main network adapter the first time you open the configuration console.

![Select Main Network Adapter](image)
The configuration console is an configuration tool for configuring Logger Runtime settings. When the configuration console is launched, it will automatically get the latest configurations from the Logger Runtime.

Configuring the MX-AOPC UA Logger Settings

The MX-AOPC UA Logger settings described below can be configured under the Tools menu.

- **Change Password**
  
  We strongly recommend changing the password the first time you use the Configuration Console. The default password is **moxa**, which is needed for verification when exporting the system log to a text file.
• **Data Supplement Settings**

Select the **Data supplement after network reconnection** checkbox if the Moxa product supporting the data supplement function is connected to an MX-AOPC UA Server.

Select the **Data supplement on schedule** checkbox if the Moxa product supporting the data supplement on schedule function is connected to an MX-AOPC UA Server.

Select the **Data Supplement through Cellular Data Access** checkbox if the IP address of the Moxa cellular device is private or dynamic.

![Data Supplement Settings](image_url)
Certificate Management

If the security policy of the MX-AOPC UA Server is set to Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both, importing an OPC UA client’s CA (Certificate Authority) file into the MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the Trust Servers tab, click Import, and select the server’s CA file to import it into the MX-AOPC UA Logger.
Select the **Instance Certificates** tab and click on **Export Logger Certificate** to export the MX-AOPC UA Logger’s CA file to the OPC UA Server.

**NOTE** After reissuing certificates or re-installing the MX-AOPC UA Logger, you will need to export the Logger Certificate to the OPC UA Server again.
Connecting to the MX-AOPC UA Server

Getting the Server Endpoint from the MX-AOPC UA Server

Open the MX-AOPC UA Server configuration console and select Tools → OPC UA Settings → Server Endpoint Settings to go to the MX-AOPC UA Server configuration console to copy the MX-AOPC UA Server’s Server Endpoint.

Ensure that the status of the Server Endpoint is Valid.

Connecting to MX-AOPC UA Servers

1. Click the Server Group and then click the Discovery icon to start discovering MX-AOPC UA Servers.
2. Select the **Local Server** option if MX-AOPC UA Server and MX-AOPC UA Logger are installed on the same computer. Otherwise, select the **Remote Server Endpoint** option and paste in the Server Endpoint from the previous step. Type in the MX-AOPC UA Server’s password and then click **Next**.
3. Modify **Server Name**, and configure **Security Policy** and **Security Mode**, which should be the same as the MX-AOPC UA Server’s UA Settings. If necessary, change the **Publish Interval**, **Sampling Interval**, **Queue Size** settings, and select or deselect the **Discard Oldest** settings checkbox, and then click **Finish**.

![Discovery Server](image)

4. Select the server and click the **Connect** icon to connect to the MX-AOPC UA Server.

![Connect](image)
5. Once the server is connected, you will not be allowed to change the server connection settings. To change the server connection settings, click the **Disconnect** icon to disconnect the MX-AOPC UA Server, and then click the **Properties** icon to change the server connection settings.

**NOTE**  
Ensure that the server connection is in connecting status before starting to record data to a database or spreadsheet.
Creating Loggers

1. To create a data logger, click **Logger Group List**, click the **New Logger Group** icon, and then type in the name of the logger group.

2. Click the logger group, and then click the **New Logger** icon to create a logger.
3. Type in the name of the logger, select **Excel File**, **Access File**, **Database**, or **Azure IoT**, and then modify the root path. Set the source name of the database, or type in the Connection String. Click **Next** to continue.

4. If necessary, modify the name and order of Table Fields. Add `<DATA_TYPE>`, `<SERVERUtc_TIMESTAMP>`, etc., if they are required to be recorded into the database or spreadsheet, and then click **Finish**.
5. Click the **Refresh** button to get the latest MX-AOPC UA Server OPC tags.

6. Click the appropriate arrow buttons to add items to or remove items from the Selected Tags list.
Starting Runtime Service

After connecting the MX-AOPC UA Server and creating the Logger, click the **Start Runtime Service** icon to start running the MX-AOPC UA Logger service.

A green light next to the logger name indicates that the logger is ready to record.
A yellow light next to the logger name indicates that the logger setting is not correct. Check the settings of the logger, and then confirm the database or spreadsheet settings again.

You will not be allowed to modify the server connection and logger settings when runtime service is running. To stop runtime service, click the **Stop Runtime Service** icon.

**NOTE**  
Configuration changes will be updated to Logger’s runtime service after the runtime service is started. If the runtime service is not started, any change will be discarded when the configuration console is closed. Be sure to save your project file when you close the configuration console.

**NOTE**  
Stopping Runtime Service will stop both the logger recording and data supplement functions, which may cause data loss.
Starting Recording

To start recording data, click the logger icon and then click the **Start Recording** icon to start recording the selected tags into the database or spreadsheet.

A red light next to the logger indicates that the logger is recording.
Click the folder icon to check if data is being recorded into the target spreadsheet.

**NOTE**  
Be sure to close the target spreadsheet listed in the target root path before starting to record. If the target spreadsheet is open, the MX-AOPC UA Logger will not be able to record data to the target file.

**NOTE**  
DO NOT open the spreadsheet while recording is under way. Doing so will cause the spreadsheet file to become corrupted because it is in use by the MX-AOPC UA Logger service. To open the spreadsheet, stop the MX-AOPC UA Logger’s runtime service and then click the folder icon to access the file.

**Testing the Data Supplement Function**

Take the following steps to test the data supplement function.

1. Insert a microSD card into your Moxa device.
2. Use IOxpress to configure the Moxa device to allocate data buffer size for network failure and to enable connection to the MX-AOPC UA Server.
3. Select the checkboxes of the tags associated with the data you would like the MX-AOPC UA Server to update.

4. If the cellular device’s SIM card uses a private or dynamic IP address, enable the Cellular Data Access function. If the SIM card is using a public IP address, continue with step 5.

5. Update the device’s configuration.
6. Conduct **Set Device Date & Time** on the device to ensure that the device, MX-AOPC UA Server, and MX-AOPC UA Logger are time synchronized.

![Set Device Date & Time][1]

7. If Cellular Data Access software is required, enable the MX-AOPC UA Logger’s **Data supplement through Cellular Data Access** option at **Tools → Data Supplement Settings**. If Cellular Data Access software is not required, continue with step 8.

![Data Supplement Settings][2]
8. Ensure that the logger is in recording mode.

9. Disconnect the Ethernet connection between the Moxa device and the MX-AOPC UA Server. Wait longer than the heartbeat interval (the ioLogik 2500’s default heartbeat interval is 30 sec.) plus the heartbeat tolerance (the MX-AOPC UA Server’s default heartbeat tolerance is 30 sec.), and then check if the tag status is "Disconnected" on the MX-AOPC UA Viewer. If it is disconnected, wait longer than the update interval of the tags, and then reconnect the connection between the Moxa device and MX-AOPC UA Server.
10. The pink and gray flashing light indicates that the logger is performing the data supplement process.

11. After the data supplement process is complete, the light will change to red. The event log will show how long the data supplement process took to perform, and the result of the supplement process.

12. Open the database folder and note which files the supplementary data has been saved to.
Testing the Data Supplement on Demand Function

Take the following steps to test the data on demand function.

1. Ensure the logger is in recording mode.

   ![Image showing logger interface with recording mode highlighted]

2. Click the **Stop Recording** button to stop recording data, and then wait.

   ![Image showing logger interface with stop recording button highlighted]
3. Click **Logger Group List** and then click the **Data Supplement on Demand** button. The default on-demand period is one day in the past.

4. Click the **Retrieve** button to start retrieving lost data in the defined period. The pink and gray flashing light indicates that the logger is performing the data supplement process.
5. Once the retrieving process is finished, the **Result** column will show **Complete**.

![Data Supplement on Demand](image)

6. To check detailed information, see the Log View at the bottom of the screen.

![Log View](image)
Testing the Data Supplement on Schedule Function

Take the following steps to test the data on demand function.

1. Ensure that the runtime service is NOT in run mode.

2. Click Tools → Data Supplement Settings.
3. Enable the **Data supplement on schedule** function, set the time (UTC Time) to a few minutes later and data loss in the past to 1 day.

![Data Supplement Settings](image)

4. Start the run time service.

![Start Run Time Service](image)
5. Start recording the logger.

![Image of MX-AOPC UA Logger interface with recording status highlighted]

6. When the specified time elapses, the data supplement on schedule function will be triggered. The progress will be displayed in the Log View as shown below.

![Image of MX-AOPC UA Logger log view showing data supplement schedule progress]
The following topics are covered in this chapter:

- **Main Screen Overview**
- **Menu Items**
  - File
  - Server
  - Logger
  - Tools
  - Runtime
  - Help
Main Screen Overview

The MX-AOPC UA Logger’s configuration console displays settings for connected MX-AOPC UA Servers and loggers. It also shows the logger runtime status.

<table>
<thead>
<tr>
<th>No.</th>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Software Title</td>
<td>Displays the name of the software: MX-AOPC UA Logger</td>
</tr>
<tr>
<td>2</td>
<td>Menu Bar</td>
<td>All configuration functions can be accessed from these menu items</td>
</tr>
<tr>
<td>3</td>
<td>Quick Launch Bar</td>
<td>Frequently used icons</td>
</tr>
<tr>
<td>4</td>
<td>Server View</td>
<td>All MX-AOPC UA Servers</td>
</tr>
<tr>
<td>5</td>
<td>Logger View</td>
<td>All Loggers</td>
</tr>
<tr>
<td>6</td>
<td>Detailed View</td>
<td>Detailed settings of the servers and loggers</td>
</tr>
<tr>
<td>7</td>
<td>Log View</td>
<td>Logger Runtime logs</td>
</tr>
<tr>
<td>8</td>
<td>Runtime Service Status</td>
<td>Indicates if the logger runtime service is <strong>Running</strong> or <strong>Stopped</strong></td>
</tr>
<tr>
<td>9</td>
<td>Logger Time</td>
<td>Displays the Logger time (same as the PC’s time)</td>
</tr>
<tr>
<td>10</td>
<td>Data Supplement Queue</td>
<td>Displays the data supplement waiting items in the queue</td>
</tr>
</tbody>
</table>
Menu Items

File

Use the **File** menu to manage project files.

- **New**: Create a new project file.
- **Open**: Open an existing project file.
- **Save**: Save the current project.
- **Save As**: Save the current project file as another project with a different filename.
- **Previous saved files**: Quickly open previously saved project files.
- **Exit**: Close the Configuration Console.
Server

Use the Server menu to edit MX-AOPC UA Server connection settings.

- **Discovery**: Discover MX-AOPC UA Servers and configure its connection settings.
- **Connect**: Connect the selected server.
- **Disconnect**: Disconnect the selected server.
- **Delete**: Delete the selected server.
- **Properties**: Modify the settings of the selected server.

**NOTE** The properties of a server cannot be modified either when the server is in connecting mode, or runtime service is in running mode. Stop runtime service and disconnect the server connection before modifying the server properties.
Logger

Use the **Logger** menu to edit logger settings.

- **New Logger Group**: Create a new logger group.
- **New Logger**: Create a new logger.
- **Delete**: Delete the selected logger.
- **Start Recording**: Start recording for a selected logger group or a selected logger.
- **Stop Recording**: Stop recording for a selected logger group or a selected logger.
- **Data Supplement on Demand**: Retrieve lost data during a specified period. Refer to Testing Data Supplement on Demand in Chapter 2.
- **Terminate Data Supplement**: Terminate all of the data supplement waiting items in the queue.
- **Properties**: Modify the settings of an existing logger.

**NOTE**  The properties of a logger cannot be modified either when the logger is in recording mode, or runtime service is in running mode. Stop runtime service before modifying logger properties.
Use the **Tools** menu to configure data supplement settings, for certificate management, to access a system log, to change a password, or to modify console environment settings.

- **Data Supplement Settings**

  ![Data Supplement Settings](image)

  - **General Settings**
    - **Retry Timeout**: 30 sec(s) (3 to 600, default: 30)
    - **Retries**: 3 (0 to 10, default: 3)
  
  - **Triggering Event**
    - **Data supplement after network reconnection**
    - **Data supplement on schedule**
    - **Everyday at**: 00:00
    - **Data loss in the past**: 1 day(s) (1 to 7, default: 1)
  
  - **Data supplement through Cellular Data Access**
    - **IP Address**: 0.0.0.0
    - **Port**: 9400 (0 to 65535, default: 9400)
  
  - **Folder for supplementary data**
    - **Path**: C:\Users\Public\Documents\Moxa\MXAOPC\  
      ![Path](image)
  
  - **Log Folder for Data Supplement on Demand**
    - **Path**: C:\Users\Public\Documents\Moxa\MXAOPC\  
      ![Path](image)
- **General Settings:**
  - **Retry Timeout:** The retry timeout interval for retrieving supplementary data from a device’s buffer.
  - **Retries:** The number of retries allowed after a retry timeout.

- **Triggering Event:** Enable the following functions if the Moxa products connected to an MX-AOPC UA Server supports the data supplement function.
  - **Data supplement after network reconnection:** Enable data supplement function after network reconnection.
  - **Data supplement on schedule:** Enable data supplement function on schedule at the specified time. The triggering time can be set to everyday at a specific time. The data loss period can be set to 1 to 7 days in the past.

- **Data supplement through Cellular Data Access:** Enable this function if the Moxa products connected to the Cellular Data Access software support the data supplement function.
  - **IP Address:** The IP address of the Cellular Data Access software.
  - **Port:** The listen port of the Cellular Data Access software.

- **Folder for supplementary data**
  - **Path:** The folder path to which the system can temporarily save supplementary data. Click to change the folder path. Click to open the folder. Delete the supplementary data files after the data is written to the database.

- **Log Folder for Data Supplementary on Demand**
  - **Path:** The folder path to which the system can temporarily save the log files of the supplementary data on demand. Click to change the folder path.
Certificate Management

If the security policy of the MX-AOPC UA Server is set to Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both, importing an OPC UA client’s CA (Certificate Authority) file into the MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the **Trust Servers** tab, click **Import**, and select the server’s CA file to import it into the MX-AOPC UA Logger. Click **Export** to export the selected certificate. Click **Remove** to remove the selected certificate. Click **Trust** to trust the selected certificate. Click **View Certificate** to view the selected certificate.
Click the **Instance Certificates** tab and click **Export Logger Certificate** to export the MX-AOPC UA Logger’s CA file to OPC UA Server.

**NOTE**
After reissuing certificates or re-installing the MX-AOPC UA Logger, you will need to export the Logger Certificate to the OPC UA Server again.

**System Log**

- **Save to Text File**: Save the MX-AOPC UA Logger’s system log to a text file. You will be required to enter a password (default password = moxa).
MX-AOPC UA Logger Configuration Console

- **Reset System Log**: Reset the MX-AOPC UA Logger’s system log. You will be required to enter a password (default password = moxa).

  ![MX-AOPC UA Logger](image)

  ![Verify Password](image)

- **System Log Settings**: Defines the maximum number of records that can be saved in the MX-AOPC UA Logger’s system log (values can range from 1 to 30000; the default value is 30000).

  ![System Log Settings](image)

- **Change Password**: Change the MX-AOPC UA Logger’s system password. The password is required when updating configurations to System Runtime, saving system logs to a text file, or resetting the system log (length: 4 to 128; acceptable characters: A to Z, a to z, 0 to 9, Symbols; default: moxa).

  ![Change Password](image)

- **Options**: Configure environment settings for the MX-AOPC UA Logger’s configuration console.

  ![Options](image)

**NOTE** If **Automatically save configuration every xx min(s)** is enabled, the configuration file will be automatically saved only when a filename is defined. Be sure to save your configuration file after creating a new project file.
Runtime

Use the Runtime menu to Start, Stop, or Reinitialize Server Runtime Service.

Help

Use the Help menu to launch the Logger’s help documentation, to check the Logger’s license status, to add a license file, or to check the logger version.

- **Logger Help:** Launch the MX-AOPC UA Logger’s help documentation.
- **Licensing**
  - **License Info:** Displays the Logger’s User Code, License Status, and the Time Remaining on the license. Refer to License Registration and Activation to learn how to activate the license.
- **Add License File:** Import a license file after completing the license registration process. Refer to **License Registration and Activation** to learn how to activate the license.

- **Deactivate License:** Deactivate the current paid license version and load factory default settings. Note that when you deactivate the license, your license file and runtime configurations will be deleted. Be sure to back up your runtime configurations before executing a license deactivation procedure.

- **About:** Displays the MX-AOPC UA Logger’s version number and build number.

![About Window](image)
The following topics are covered in this chapter:

- **Server Discovery**
  - Getting the Server Endpoint from an MX-AOPC UA Server
  - Discovering MX-AOPC UA Servers

- **Server Connection**
  - Connecting to the discovered MX-AOPC UA Server
  - Editing the connection settings of the discovered MX-AOPC UA Server
  - Deleting the connection settings of the discovered MX-AOPC UA Server
Server Discovery

In this section we explain how to discover an MX-AOPC UA Server.

An MX-AOPC UA Logger can discover MX-AOPC UA Servers installed on a local or remote computer. First, get the server endpoint, and then follow the onscreen instructions to discover the server. After the server has been discovered, be sure to connect to the server before adding the tags into loggers for recording.

**NOTE**  The server discovery or server connection settings can only be configured when runtime service status is stopped. To stop the runtime, click the stop runtime icon on the quick launch bar.

Getting the Server Endpoint from an MX-AOPC UA Server

1. Open the MX-AOPC UA Server configuration console by clicking **Tools → OPC UA Settings → Server Endpoint Settings**. Be sure the status of the Server Endpoint is valid, and then copy the Server Endpoint of the MX-AOPC UA Server.

2. Go to **Tools → OPC UA Settings → Security Policy Setting** and confirm the MX-AOPC UA Server’s security policy settings. The security policy is applied to connections between OPC UA clients and the MX-AOPC UA Server. If Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both of these options are selected, you will need to configure **Certificates Management** settings on both MX-AOPC UA Server (**Tools → OPC UA Settings → Certificates Management**) and MX-AOPC UA Logger (**Tools → Certificate Management**). If only “None” is selected, you only need to know the password of the MX-AOPC UA Server.
Discovering MX-AOPC UA Servers

1. Go to the MX-AOPC UA Logger, right click a Server Group and then click Discovery in the pop up menu, or click the Server Group to select it and then click the Discovery icon on the quick launch toolbar to start discovering MX-AOPC UA Servers.

2. Select Local Server if the MX-AOPC UA Server and MX-AOPC UA Logger are installed on the same computer, or click Remote Server Endpoint and type in the target Server Endpoint. Next, type in the password of the MX-AOPC UA Server, and then click the Next button.
3. Modify **Server Name**, and configure **Security Policy** and **Security Mode** to be the same as the MX-AOPC UA Server's UA Settings. If necessary, update the **Publish Interval**, **Sampling Interval**, **Queue Size**, or **Discard Oldest** settings, and then click **Finish**.

- **Server Name**: Give a name for the connection of the MX-AOPC UA Server (max. length = 30; a period “.” is not allowed). The server name should be unique and cannot be modified after you click **Finish**.
- **Server Endpoint**: The server endpoint of the discovered MX-AOPC UA Server.
- **Security Policy**: Configure the same security policy as the MX-AOPC UA Server.
- **Security Mode**: Configure the same security mode as the MX-AOPC UA Server.
- **Subscription Settings**: Configure the subscription settings for MX-AOPC UA Logger to receive OPC tag data from the MX-AOPC UA Server.
  - **Publish Interval**: The publish interval defines the rate at which the Server sends OPC tag data to the Logger (unit: ms; values: 0 to 86400000; default: 1000; 0: the fastest practical rate).
  - **Keep Alive Count**: The keep alive count defines the number of publish intervals that must expire before a keep alive message is sent to MX-AOPC UA Server.
  - **Lifetime Count**: The lifetime count defines the number of times of publish interval can expire without the MX-AOPC UA Logger sending data updates or keep alive messages before the server deletes the subscription.
- **Monitored Item Settings**
  - **Sampling Interval**: The sampling interval defines the rate at which the server checks for changes in the monitored device readings (unit: ms; values: -1 to 86400000; default: 500; the default interval set by the server: -1; the fastest practical rate: 0).
  - **Queue Size**: The queue size defines the number of data updates that the OPC UA Server will queue for the subscription.
- **Discard Oldest:** The discard oldest defines the discard policy of the queue. When checked, the oldest notification in the queue will be discarded and will not be sent to the MX-AOPC UA Logger. When unchecked, the latest notification will be discarded and will not be sent to the MX-AOPC UA Logger (default setting: enabled).

**Server Connection**

In this section we explain how to connect to the discovered MX-AOPC UA Server, and how to modify the connection settings.

**Connecting to the discovered MX-AOPC UA Server**

Before configuring the logger, you must first connect to the discovered MX-AOPC UA Server to get the OPC tag list from the servers.

1. Ensure the runtime service is stop.
2. Right click the server and click **Connect** in the pop up menu, or click the server to select it and then click the **Connect** icon on the quick launch toolbar. The server should now be connected to the MX-AOPC UA Logger.
Editing the connection settings of the discovered MX-AOPC UA Server

Take the following steps to edit the connection settings of the discovered MX-AOPC UA Server:

1. Ensure the runtime service is stopped.
2. Right click the server and click **Disconnect** in the pop up menu, or click the server to select it and then click the **Disconnect** icon on the quick launch toolbar.
3. Right click the server and click **Properties** in the pop up menu, or click the server to select it and then click the **Properties** icon on the quick launch toolbar. Follow the onscreen instructions to edit the settings.

**NOTE**  The server name cannot be modified after the initial setting. To change the server name, delete the original server settings and then use the server discovery process to create a new one. Note that deleting the server connection settings will delete all of the related logger settings at the same time.
Deleting the connection settings of the discovered MX-AOPC UA Server

Take the following steps to delete the connection settings of the discovered MX-AOPC UA Server:

1. Ensure the runtime service is stopped.
2. Right click the server and click **Delete** in the popup menu, or click the server to select it and then click the **Delete** icon on the quick launch toolbar.

3. Click **OK** to confirm that you would like to delete logger settings at the same time.
The following topics are covered in this chapter:

- **Logger Group**
  - Adding a Logger Group to a Logger Group List
  - Editing a Logger Group
  - Deleting a Logger Group

- **Loggers**
  - Adding a Logger to a Tag Group
  - Editing a Logger
  - Deleting a Logger

- **Logger Recording**
  - Select Tags for Recording
  - Start or Stop Recording
  - Logger Status
Logger Group

In this section we explain how to use the configuration console to add, edit, and delete logger groups.

Adding a Logger Group to a Logger Group List

1. Ensure that the runtime service is stopped.
2. Right click the Logger Group List and then click New Logger Group in the popup menu, or click the Logger Group List to select it and then click the New Tag Group icon on the Quick Launch toolbar.

3. Type in the name of the logger group (max. length = 30 characters; "." is not allowed) and then click OK.
4. The new logger group will be added to the Logger Group List.

Editing a Logger Group

Right click the logger group and then click **Properties** in the popup menu, or click the logger group to select it and then click the **Properties** icon on the Quick Launch toolbar.

Deleting a Logger Group

Right click the logger group and then click **Delete** in the popup menu, or click the logger group to select it and then click the **Delete** icon on the Quick Launch toolbar.
Loggers

In this section we explain how to use the configuration console to add, edit, and delete loggers.

Adding a Logger to a Tag Group

1. Ensure the runtime service is stopped.
2. Right click on the logger group that the logger will be added to and then click New Logger in the popup menu, or click the logger group to select it and then click the New Logger icon on the Quick Launch toolbar.
3. Type in the name of the logger, configure the data file type, database or Azure IoT, and then click **Next**.

- **Logger Name**: The naming rules of the logger name depend on the specifications of Microsoft Excel, Access, SQL Server, Oracle Database, or Azure IoT. The naming rules can be summarized as follows:
  - Microsoft Excel (max. length = 30; the first four characters: a-z, A-z; the following characters: 0-9, a-z, A-Z, _)
  - Microsoft Access (max. length = 30; the following characters are NOT allowed: . ! ` [ ] ' ,)
  - Database Source Name (DSN) and Azure IoT (max. length = 30 (only 20 if using Oracle Database); the following characters are NOT allowed: . [ ] ',')

- **Excel File**: Select this option if you would like to record data into Excel files. Configure the root path for saving those files. Configure the time if you would like to separate the files by interval.

- **Access File**: Select this option if you would like to record data into Access files. Configure the root path for saving those files.

- **Database**: Select this option if you would like to record data into a Microsoft SQL Server or Oracle database. Refer to Appendix B for details on how to configure the database connection settings.

- **Azure IoT**: Select this option if you would like to record data in a Microsoft Azure IoT Cloud. Copy the Connection String you got from Microsoft Azure and paste it into this field.
4. Select the Data Field items, change the default names in the Table Field, change the order of the items, and if necessary change the time format for the timestamp. Click Finish to save the settings.

- **Data Field**: By default, data of `<TAG_ID>`, `<VALUE>`, `<UNIT>`, `<SOURCE_UTC_TIMESTAMP>`, `<SOURCE_TIMEZONE>` will be recorded into the database. Data of `<DATA_TYPE>`, `<SERVER_UTC_TIMESTAMP>`, `<SERVER_TIMEZONE>`, and `<QUALITY>` are optional. The time data of `<SOURCE_UTC_TIMESTAMP>` and `<SOURCE_TIMEZONE>` in an OPC tag is added by Moxa's I/O device when the event occurs. The time data of `<SERVER_UTC_TIMESTAMP>` and `<SERVER_TIMEZONE>` in an OPC tag is added by the MX-AOPC UA Server when the tag is received.

- **Table Field**: The name of each data field, which can be defined by the user, will be the column name of the table in the database. The max. length is 30 characters. The following characters are not allowed: ! # $ [ ] { } " ' ? . , `.

- **Data Type**: The data type of the timestamp can be either DateTime or String type. If the second value of the timestamp has decimal points, select String type to record the decimal point value into the database. The DateTime format only supports integer values.

- **Move the selected item up**: 

- **Move the selected item down**: 

- **Automatically start recording when service starts running**: Enable this function if you want the logger to start recording automatically whenever the runtime service starts running.
Editing a Logger

Take the following steps to edit a logger’s properties:

1. Ensure the runtime service is stopped.
2. Right click the logger and then click **Properties** in the popup menu, or click the logger to select it and then click the **Properties** icon on the Quick Launch toolbar.
Deleting a Logger

Take the following steps to delete a logger:

1. Ensure the runtime service is stopped.
2. Right click the logger and click **Delete** in the popup menu, or click the logger to select it and then click the **Delete** icon on the quick launch toolbar.

3. Click **OK** to confirm that you would like to delete this logger.
Logger Recording

In this section we explain how to use the configuration console to select tags for recording, to start or stop recording, and to check the status of a logger.

Select Tags for Recording

1. Ensure the runtime service is stopped.
2. Ensure that the server is connected.
3. Click the refresh button to get the updated tags from the server.
4. Select the tag in the Available Tags list and click the arrow button to add it into the Selected Tags list.

- : add all tags into the Selected Tags list.
- : add a selected tag into the Selected Tags list.
- : remove a selected tag from the Selected Tags list.
- : removed all tags from the Selected Tags list.

5. The data from the tags in the list shown below will be recorded after the logger is in recording mode.
Start or Stop Recording

1. Ensure the runtime service is running.
2. Ensure the server is connected.
3. Ensure the logger is in ready mode (indicated by green lights).
4. To start recording all loggers in one logger group, right click on the logger group and then click Start Recording in the popup menu, or click the logger group to select it and then click the Start Recording icon on the Quick Launch toolbar.

5. All of the loggers in the logger group will be in recording mode (indicated by red lights).
6. To start recording a specific logger, right click on the logger and then click **Start Recording** in the popup menu, or click the logger to select it and then click the **Start Recording** icon on the Quick Launch toolbar.

7. To stop recording, right click on the logger group or the logger and then click **Stop Recording** in the popup menu, or click the logger group or the logger to select it and then click the **Stop Recording** icon on the Quick Launch toolbar.
8. To check the recorded data, stop the runtime service and click the data folder of the logger. Open the data file in the folder to check the recorded data.

**NOTE**  Be sure to close the Excel or Access file at the target root path before starting to record. Otherwise, the MX-AOPC UA Logger will not be able to record data to the target file.

**NOTE**  DO NOT open the spreadsheet when recording. Doing so will cause the file to be corrupted because it is already opened by the MX-AOPC UA Logger service. To open the spreadsheet, stop the runtime service of the MX-AOPC UA Logger, and then click the folder icon to access the file.
## Logger Status

The following table gives the meanings of the logger status indicator lights.

<table>
<thead>
<tr>
<th>Light</th>
<th>Color</th>
<th>Status</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Solid Gray</td>
<td>Configurable Mode</td>
<td>The logger can be configured only when runtime service stops. Any configuration change will be updated to the Logger’s runtime service after starting the runtime service. Without starting the runtime service, any change will be discarded after the configuration console is closed. Be sure to save your project file when you close the configuration console.</td>
</tr>
<tr>
<td></td>
<td>Solid Green</td>
<td>Ready Mode</td>
<td>The logger is ready for recording.</td>
</tr>
<tr>
<td></td>
<td>Solid Red</td>
<td>Recording Mode</td>
<td>The logger is recording.</td>
</tr>
<tr>
<td></td>
<td>Solid Yellow</td>
<td>Error Mode – Configuration</td>
<td>The logger is not configured correctly, and data is not being saved to the database. Check the tag selection or database connection of the logger.</td>
</tr>
<tr>
<td></td>
<td>Flashing Red and Yellow</td>
<td>Error Mode – Server</td>
<td>A server related to some selected tags is disconnected. Check the server connection or server’s Endpoint settings.</td>
</tr>
<tr>
<td></td>
<td>Flashing Pink and Gray</td>
<td>Data Supplement Mode</td>
<td>The logger is retrieving supplementary data from device’s buffer storage or supplementing data into the database.</td>
</tr>
</tbody>
</table>
License Registration and Activation

Three versions of the MX-AOPC UA Logger are available. The trial version, which supports up to 1 MX-AOPC UA Server connection and up to 1 data logger, can be installed and used for 30 days without registration. To use the free and paid versions you must submit a license registration. Both free and paid versions can be used indefinitely, but the free version only supports up to 1 MX-AOPC UA Server connection and up to 1 data logger.

The three versions are summarized in the following table:

<table>
<thead>
<tr>
<th>Version</th>
<th>MX-AOPC UA Server connection</th>
<th>Data Logger</th>
<th>Run Time</th>
<th>License File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trial</td>
<td>Up to 1</td>
<td>Up to 1</td>
<td>30 days</td>
<td>Not Required</td>
</tr>
<tr>
<td>Free</td>
<td>Up to 1</td>
<td>Up to 1</td>
<td>Unlimited</td>
<td>Required</td>
</tr>
<tr>
<td>Paid</td>
<td>Up to 2</td>
<td>Up to 10</td>
<td>Unlimited</td>
<td>Required</td>
</tr>
</tbody>
</table>

Take the following steps to register a license.

**Step 1:**
Get the PC User Code from the MX-AOPC UA Logger’s configuration console by clicking Help → License. For the paid version, you will need to purchase a registration code from your Moxa distributor. The Registration Code can be found on the product label.

![License Info](image)

![Moxa Product Label](image)
Step 2:
Go to Moxa’s Software Licensing website (http://license.moxa.com) and log in with your Moxa account and password, or apply for an account if this is your first visit to the site.

Step 3:
On the Software Licensing website, navigate to **Activate Your Software → Software Package → MX-AOPC UA Logger**. Select **Free Version** and enter the User Code, or select **Paid Version** and enter both the User Code and Registration Code.

Step 4:
Download the license file to a folder on your PC and unzip it.

Step 5:
From the MX-AOPC UA Logger’s configuration console, click **Help → Licensing → Add License File** to add the license file (.lic) to the MX-AOPC UA Logger.
Step 6:
After license activation is complete, go to Help → License Info to check the current license status.
These performance results provide a reference for evaluating MX-AOPC UA Logger’s capability when designing a system architecture. The results show the maximum number of tags of data that can be recorded into the database without resulting in a data queue.

- **CPU:** i7-4790, 3.60 GHz
- **RAM:** 8 GB
- **Operating System:** Microsoft Windows 7
- **Editor:** Microsoft Office 2010 Access and Excel
- **Database:** Oracle database, Microsoft SQL Server, MySQL
- **OPC UA Software:** MX-AOPC UA Server & MX-AOPC UA Logger
- **Cloud:** Azure IoT
- **Test Case:**
  - One database at a time
  - Disabled data supplement function
  - Only running real-time data recording function

<table>
<thead>
<tr>
<th>Database Type</th>
<th>Database</th>
<th>Max. No. of Tags (per 1 second)</th>
<th>Max. No. of Tags (per 5 seconds)</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Excel</td>
<td>2000</td>
<td>10000</td>
</tr>
<tr>
<td>File</td>
<td>Access</td>
<td>3000</td>
<td>15000</td>
</tr>
<tr>
<td>DSN</td>
<td>Excel</td>
<td>2000</td>
<td>10000</td>
</tr>
<tr>
<td>DSN</td>
<td>Access</td>
<td>3000</td>
<td>15000</td>
</tr>
<tr>
<td>DSN</td>
<td>Microsoft SQL</td>
<td>1300</td>
<td>6500</td>
</tr>
<tr>
<td>DSN</td>
<td>Oracle</td>
<td>2000</td>
<td>10000</td>
</tr>
<tr>
<td>DSN</td>
<td>MySQL</td>
<td>800</td>
<td>4000</td>
</tr>
<tr>
<td>Cloud</td>
<td>Azure IoT</td>
<td>30</td>
<td>150</td>
</tr>
</tbody>
</table>
In this chapter, we explain how to connect a Logger to a Microsoft SQL Server or Oracle database.

1. Open **ODBC Data Source Administrator** by typing "odbcad32.exe" in the Windows Start search field, and then click it.
2. Click the System DNS tab and then click Add.

3. Select **ODBC driver for Oracle** if you are using an Oracle database, and select **ODBC Driver xx for SQL Server** if you are using a Microsoft SQL Server. In the example shown below, "ODBC Driver 11 for SQL Server" is selected. Click **Finish** to go to the next step.

**NOTE** MX-AOPC UA Logger supports Oracle database (x86) and Microsoft SQL Server (x86) connections.
4. Type a name for the data source in the **Name** field. Click the **Server** field down arrow to search for instances of SQL Server. Select your target SQL Server, and then click **Finish**.

5. Click **Test Data Source** to test the connection, or click **OK** to proceed.
6. Click **OK** to complete ODBC Data Source settings.
7. Open Microsoft SQL Server Manage Studio. Right click on **Security \ Logins \ NT AUTHORITY\SYSTEM**, and then click **Properties**.
8. Ensure the default database is master.
9. Ensure that **Public** for Server Roles is enabled.
10. Enable the **Master** Database of the User Mapping, and enable the **db_owner** and **public** roles of the master.
11. Select the **Database** option when setting the Logger’s data destination, and then click **Setting**.

12. Click the **Machine Data Source** tab, select the SQL Server data source, and then click **OK**.

**NOTE**  
DO NOT click **NEW** from this window to configure ODBC Data Source settings. You will not be able to successfully connect the logger with the database.
13. The data source name is displayed in the **Source Name** field. Click **NEXT** to continue the Logger Settings. Refer to Chapter 5 for information about the following settings.