Using Siemens S7-300 PLC to Perform Acyclic Read and Write on MGate 5102

Moxa Technical Support Team
support@moxa.com

Contents

1. Application Description ................................................................. 2
2. System Topology .............................................................................. 2
3. Hardware and Software Requirements ........................................... 3
   3.1. Hardware Requirement ................................................................. 3
   3.2. Software Requirement ................................................................. 3
4. Configuration .................................................................................. 3
   4.1. Hardware Installation ................................................................. 3
   4.2. Configuring MGate 5102-PBM-PN ............................................. 3
   4.3. Configuring MGate 4101-MB-PBS ............................................. 4
   4.4. Configuring Siemens PLC .......................................................... 4
   4.5. Configuring Siemens PLC Acyclic Read/Write Operation .......... 12
   4.6. Creating the Variable Table ...................................................... 22
   4.7. Downloading a Project to PLC .................................................. 23
   4.8. Configuring GP- Pro EX .......................................................... 24
5. Communication Test ..................................................................... 32
   5.1. Performing HMI Test ............................................................... 32
   5.2. Using the Variable Table .......................................................... 34

About Moxa

Moxa is a leading manufacturer of industrial networking, computing, and automation solutions. With over 25 years of industry experience, Moxa has connected more than 30 million devices worldwide and has a distribution and service network that reaches customers in more than 70 countries. Moxa delivers lasting business value by empowering industry with reliable networks and sincere service for automation systems. Information about Moxa’s solutions is available at www.moxa.com. You may also contact Moxa by email at info@moxa.com.

How to Contact Moxa

Tel: +886-2-8919-1230
Fax: +886-2-8919-1231
Moxa Tech Note

Using Siemens S7-300 PLC to Perform Acyclic Read and Write on MGate 5102

1. Application Description

A. Objective

This document describes how to use Siemens PLC to perform Acyclic Read and Write on MGate 5102-PBM-PN to get PROFIBUS Status Word and Communication List or to set PROFIBUS Control Word.

In this application, the administrator wants to manage MGate 5102-PBM-PN diagnostic information. For example, to get and set PROFIBUS operation mode and to get PROFIBUS Communication List via Siemens PLC.

B. Goals

This document shows you how to:
- Use Siemens PLC to do Acyclic Read and Write.
- Get PROFIBUS Status Word and PROFIBUS Communication List from MGate 5102-PBM-PN.
- Set PROFIBUS Control Word from MGate 5102-PBM-PN.

2. System Topology

The following figure shows a system architecture in which MGate 5102-PBM-PN, PC1 (running SIMATIC Step 7), Siemens S7-300 PLC, and Pro-face GP-4501 TW (a HMI device to control and monitor PLC) are connected to the Ethernet network. MGate 5102-PBM-PN connects to MGate 4101-MB-PBS via a PROFIBUS cable. Pro-face GP-4501TW controls and monitors Siemens S7-300 via Ethernet.
3. Hardware and Software Requirements

3.1. Hardware Requirement
A. Siemens SIMATIC S7-300 PLC:
   Processor: CPU 315-2 PN/DP
   Article Number: 6ES7315-2EH14-0AB0
   Version: 3.2.7

B. MGate 5102-PBM-PN:
   Firmware Version: V1.2_Build_13083010
   GSDML File: GSDML-V2.3-Moxa-MGate-20130708.xml

C. MGate 4101-MB-PBS:
   Firmware Version: Ver1.3_Build_14031018
   GSD File: MPBS0D80.gsd.

3.2. Software Requirement
A. SIMATIC Step7:
   Siemens PLC Engineering Software by Siemens AG.
   Version: V5.5+SP3

B. MGate Manager:
   Software utility to configure Moxa MGate devices.
   Version: 1.10

C. GP-Pro EX:
   Screen editor Utility from Pro-face.
   Rev.: V3.5

4. Configuration

4.1. Hardware Installation
A. Ethernet Connection
   Use Ethernet cables to connect Siemens PLC, MGate 5102-PBM-PN, and
   Pro-face GP-4501TW to an Ethernet switch.

B. PROFIBUS Connection
   Use a PROFIBUS cable to connect MGate 5102-PBM-PN to MGate
   4101-MB-PBS.

4.2. Configuring MGate 5102-PBM-PN
   Use MGate Manager to configure the following MGate 5102-PBM-PN settings.
   A. PROFINET Setting
      Set [Device Name] to “mgate-dev”.
B. PROBUS Setting
- Add MGate 4101 to the Slave List with the address 3.
- Set the IO modules as (Slot 1): “Input 1 Word” and (Slot 2): “Output 1 Word”.

4.3. Configuring MGate 4101-MB-PBS
- On the switch, set the PROFIBUS address as 3.
- In MGate Manager, set the PROFIBUS IO on MGate 4101-MB-PBS to (Slot 1): “Input 1 Word” and (Slot 2): “Output 1 Word”.

4.4. Configuring Siemens PLC
4.4.1. Creating a STEP 7 Project
Start SIMATIC Manager and create a new project. Click File → New. Then, set the project name in the Name field and click OK.
4.4.2. Inserting a Station
In SIMATIC Manager, click Insert → Station and select to insert SIMATIC 300 Station into the project.

4.4.3. Configuring Hardware
A. Adding a Rack
1. In SIMATIC Manager, double-click Hardware.
2. The **HW Config** screen appears. Click **Insert** \(\rightarrow\) **SIMATIC 300** \(\rightarrow\) **RACK** \(\rightarrow\) **Rail** to insert the rack object.

The following figure shows the HW Config screen after adding the rack object.
B. Adding a CPU

You must add the appropriate CPU module to the STEP7 project based on the actual hardware model. In this example, **CPU 315-2 PN/DP** is the hardware model.

1. In the HW Config screen, drag the selected CPU module to the slot table.

The **Properties-Ethernet interface PN-IO** screen appears.

2. Configure the **IP address** and **Subnet mask** fields for Siemens PLC. Click **New** to add a new subnet as “Ethernet(1)”. Then, click **OK**.
4.4.4. Installing the GSD file

For engineering and configuration purposes, you must the device’s GSDML file through SIMATIC Manager.

A. In the HW Config screen, click **Options → Install GSD File.**
B. In the Instll GSD Files screen, click **Browse** to navigate to the folder and select the GSDML file for the Moxa PROFINET device. Then, click **Install** and **Close**.

If the GSD file is installed successfully, the system displays **Moxa PROFINET Device** in the the hardware catalog list.
4.4.5. Configuring the PROFINET IO Device

In the HW Config screen, select and drag Moxa PROFINET Device from the hardware catalog list to PROFINET IO → Additional Field Devices as shown in the following figure.

The following figure shows the topology with the Moxa PROFINET Device object graphic.
You can double-click "(1)maget-dev" of Moxa PROFINET Device object to configure its properties.
4.4.6. Configuring I/O Modules

You can configure the selected I/O modules for data exchange with Siemens PLC. You can select the I/O module combinations based on your application. This example uses the **Input 2 Byte** and **Output 2 Byte** IO combination.

A. Drag the **Input 002 Byte** module from the module list for Moxa PROFINET Device to slot 1.
B. Drag the **Output 002 Byte** module to slot 2.
C. Save the changes.

4.5. Configuring Siemens PLC Acyclic Read/Write Operation

4.5.1. Inserting Data Block

You must first add data blocks to configure request and response parameters.

A. In the SIMATIC Manager screen, click **Insert → S7 Block → Data Block** to add data blocks.
B. In the Properties screen, configure the fields and click **OK** to create two data blocks. Enter the field values as listed in the following table.

<table>
<thead>
<tr>
<th>Name</th>
<th>DB1</th>
<th>DB2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbolic Name</td>
<td>DB_Request</td>
<td>DB_Response</td>
</tr>
</tbody>
</table>

![Data Block Properties](image)

![Data Block Properties](image)
4.5.2. Copying SFB52 and SFB53

SFB52 and SFB53 function blocks are used for read and write requests on Siemens PLC.

Complete the following steps to copy these function blocks to your project:

A. In the SIMATIC Manager screen, click File → Open and click the Library tab.

B. Select Standard Library and click OK to open the pre-defined library.

C. From the Standard Library tree view, click System Function Blocks → Blocks.

D. On the right panel, select SFB52 and SFB53 and click Copy to copy them to your projects.
4.5.3. Adding SFB52 and SFB53 Instance DB

Add two data blocks for SFB52 and SFB53. To create the data blocks, configure the fields in the Properties – Data Block screen as shown in the following table.

<table>
<thead>
<tr>
<th>Name and type</th>
<th>DB52 Instance DB</th>
<th>DB53 Instance DB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbolic Name</td>
<td>SFB52_Instance</td>
<td>SFB53_Instance</td>
</tr>
</tbody>
</table>

For more information on accessing the Properties – Data Block screen, see the Inserting Data Block section.

The following figures show the Properties – Data Block screen.
After adding the two data blocks, the SIMATIC Manager displays the entries as shown in the following figure.

4.5.4. Configuring DB1

Click the DB1 data block to configure the structure variable as shown in the following figure.
4.5.5. Configuring DB2

Click the DB2 data block to configure the structure variable as shown in the following figure.

<table>
<thead>
<tr>
<th>Address</th>
<th>Name</th>
<th>Type</th>
<th>Initial value</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+1</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+2</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+3</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+4</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+5</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+6</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+7</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+8</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+9</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+10</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+11</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+12</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+13</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+14</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+15</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+16</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+17</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
<tr>
<td>+18</td>
<td>StatusWordDB</td>
<td>BYTE</td>
<td>0x000000</td>
<td></td>
</tr>
</tbody>
</table>

4.5.6. Programing Acyclic Read to MGate to set getting Status Word

A. Insert **Network 2** to program Read Status Word.

B. Under **SFB blocks**, drag **SFB52** to **Network 2** and configure the input and output parameters as shown in the following figure.
The following describes the parameters.

- **REQ**: The Read request is sent to MGate 5102-PBM-PN using bit memory M1.0. Enter 1 (true) to start the read request. The request should then be ended. Enter 0 (false) to end the request. A Reset Bit logic is used to reset M1.0.
- **VALID**: Bit memory M1.1 indicates whether a new data record was received and valid.
- **BUSY**: Bit memory M1.2 indicates whether the read process is terminated or not.
- **ERROR**: Bit memory M1.3 indicates whether an error has occurred while processing the function.
- **STATUS**: The double-word bit memory MD10 contains an error code. For error descriptions, see "Help on system functions / function blocks".
- **ID**: The PN-IO diagnostic address (for example, “2041”). This address is used for PROFINET acyclic read/write to MGate5102-PBM-PN to perform pre-defined diagnoses.
- **INDEX**: Data record number. For MGate5102-PBM-PN Status Word, the starting address is 1024.
- **MLEN**: Maximum length in bytes of the data record information to be fetched. For MGate5102-PBM-PN Status Word, the length is 2 bytes.
- **RECORD**: Destination area for the read data record. For DB 2 in this example, the starting address is 0 and the address length is 2 bytes.
4.5.7. Programming Acyclic Read to MGate to Get the Communication List

The following describes the parameters.

- **REQ**: The Read request is sent to MGate 5102-PBM-PN using bit memory M2.0. Enter 1 (true) to start the read request. The request should then be ended. Send a value of 0 (false) to end the request. A Reset Bit logic is used to reset M2.0.
- **VALID**: Bit memory M2.1 indicates whether a new data record has been received and valid.
- **BUSY**: Bit memory M2.2 indicates whether the read process is terminated or not.
- **ERROR**: Bit memory M2.3 indicates whether an error has occurred while processing the function.
- **STATUS**: The double-word bit memory MD10 contains an error code. For error descriptions, see "Help on system functions / function blocks".
- **ID**: The PN-IO diagnostic address (for example, "2041"). This address is used for PROFINET acyclic read/write to MGate5102-PBM-PN to perform pre-defined diagnoses.
- **INDEX**: Data record number. For MGate5102-PBM-PN Status Word, the starting address is 1024.
- **MLEN**: Maximum length in bytes of the data record information to be fetched. For MGate5102-PBM-PN Communication List, the length is 16 bytes.
- **RECORD**: Destination area for the read data record. For DB 2 in this example, the starting address is 2 and the address length is 16 bytes.
4.5.8. Programing Acyclic Write to MGate 5102-PBM-PN to Set Control Word

In SIMATIC Manager, double-click **OB1** under **S7 Program → Blocks**. The **OB1** block is a **Program Cycle Organization Block**. The operating system of the S7 CPU executes OB1 periodically. When OB1 has been executed, the operating system starts it again. Cyclic execution of OB1 is started after the startup has been completed.

A. Click **OB1** to edit the program.
B. Insert **Network 1** to program Write Control Word.
C. Under **SFB blocks**, drag **SFB53** to **Network 1** and configure the input and output parameters as shown in the following figure.

The following describes the parameters.

- **REQ**: The write request ("Write parameter") is sent to MGate 5102-PBM-PN using bit memory M0.0. Enter **1** (true) to start the write request. The request should then be ended. Send a value of **0** (false) to end the request. A Reset Bit logic is used to reset M0.0.
- **DONE**: Bit memory M0.1 indicates whether a data record has been transferred.
- **BUSY**: Bit memory M0.2 indicates whether the write process is terminated or not.
- **ERROR**: Bit memory M0.3 indicates whether an error has occurred while processing the function.
- **STATUS**: The double-word bit memory MD10 contains an error code. For error descriptions, see "Help on system functions / function blocks".
Using Siemens S7-300 PLC to Perform Acyclic Read and Write on MGate 5102

- ID: The PN-IO diagnostic address (for example, “2041” as shown in the following figure). This address is used for PROFINET acyclic read/write on MGate5102-PBM-PN to perform pre-defined diagnoses.
- INDEX: Data record number. For MGate5102-PBM-PN Control Word, the starting address is 1024.
- LEN: Length of the fetched data record information. For MGate5102-PBM-PN Control Word in this example, the length is 2 bytes.
- RECORD: Write Out Data Record. For DB 1, the starting address is 0 and the address length is 2 bytes.
4.6. Creating the Variable Table

In the variable table, you can modify and monitor the connected PLC variables and memory content.

To insert a variable table in the SIMATIC Manager screen, click **Insert → S7 Block → Variable Table**.

Add the variables as shown in the following figure and save the changes.

<table>
<thead>
<tr>
<th>Address</th>
<th>Symbol</th>
<th>Display format</th>
<th>Status value</th>
<th>Modify value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>M 0.0</td>
<td>BOOL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>M 1.0</td>
<td>BOOL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>/Read “Control Word” Request Trigger</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>M 2.0</td>
<td>BOOL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>/Read “Communication List” Request Trigger</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>DB1.DBW 0</td>
<td>HEX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>/Read Word</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>DB2.DBW 0</td>
<td>HEX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>/Control Word</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>DB1.DBW 0</td>
<td>HEX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>/Communication List</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>DB2.DB 2</td>
<td>&quot;DB_Response&quot; Slave000007</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>DB2.DB 3</td>
<td>&quot;DB_Response&quot; Slave000015</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>DB2.DB 4</td>
<td>&quot;DB_Response&quot; Slave000023</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>DB2.DB 5</td>
<td>&quot;DB_Response&quot; Slave000031</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>DB2.DB 6</td>
<td>&quot;DB_Response&quot; Slave000039</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>DB2.DB 7</td>
<td>&quot;DB_Response&quot; Slave000047</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>DB2.DB 8</td>
<td>&quot;DB_Response&quot; Slave000055</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>DB2.DB 9</td>
<td>&quot;DB_Response&quot; Slave000063</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>DB2.DB 10</td>
<td>&quot;DB_Response&quot; Slave000071</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>DB2.DB 11</td>
<td>&quot;DB_Response&quot; Slave000079</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>DB2.DB 12</td>
<td>&quot;DB_Response&quot; Slave000087</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>DB2.DB 13</td>
<td>&quot;DB_Response&quot; Slave000095</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>DB2.DB 14</td>
<td>&quot;DB_Response&quot; Slave000103</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>DB2.DB 15</td>
<td>&quot;DB_Response&quot; Slave000111</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>DB2.DB 16</td>
<td>&quot;DB_Response&quot; Slave000119</td>
<td>HEX</td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>DB2.DB 17</td>
<td>&quot;DB_Response&quot; Slave000125</td>
<td>HEX</td>
<td></td>
</tr>
</tbody>
</table>
4.7. Downloading a Project to PLC

In the SIMATIC Manager screen, click the **Download to Module** icon to download the configuration to **CPU 315-2 PN/DP**.

PLC starting communicating with MGate 5102-PBM-PN. The **PN Status** (PROFINET) LED on MGate 5102-PBM-PN turns **steady green** which indicates that the PROFINET status of the device is in **RUN** mode.
4.8. Configuring GP-Pro EX

4.8.1. Creating a New project

A. Start the GP-Pro EX application.

B. The Welcome to GP-Pro EX window appears. Select New and click OK.

C. Configure the following Display Unit settings and click Next.
   - **Series**: Select **GP 4000 Series** and **GP-45** Series from the drop-down lists.
   - **Model**: Select **GP-4501TW** from the drop-down list.
D. In the Device/PLC screen, configure the following fields and click **New Screen**:

- **Manufacture**: Select **Siemens AG** from the drop-down list.
- **Series**: Select **SIMATIC S7 Ethernet** from the drop-down list.
- **Port**: Select **Ethernet (TCP)** from the drop down list.

The system closes the Welcome screen and creates a Base Screen as shown in the following figure.

### 4.8.2. PLC Connection Setup

A. Click the **Project** tab and select **Device/PLC**.

B. In the **Device/PLC 1** configuration area, click the icon next to **PLC1** as indicated in the following figure.
C. In the PCI settings screen, configure the following fields and click **New**:

- **Destination IP Address**: Enter the IP address.
- **Connection Type**: Select **OP Communication** from the drop-down list.
- **CPU Rack Number**: Enter “0”.
- **CPU Slot Number**: Enter “2”.
- **Use Tag Data**: Select this check box.
D. The **Add Tag** screen appears. Click **Import**.

E. In the **Tag Import** screen, select **DB_Request** and **DB_Response**; then, click **OK**.
F. In the **Tag List** screen, click **Add** to add the BOOL tags as shown in the following figure.

Create a new Screen and insert the parts as shown in the following figure.
The following figure shows a Control Word/Status Word input box example.
The following figure shows a Control Word/Status Word input box example.
The following figure shows a Communication List input box example.
5. Communication Test

5.1. Performing HMI Test

5.1.1. Write Control Word Test

A. Log in to the MGate 5102-PBM-PN web console. Click **System Management** → **Maintenance** → **PROFIBUS Control** and change the switch operation mode to **Stop**.

B. In the HMI panel, select the Input Control Word input box and enter 3 on pop-up keypad.

C. In the HMI panel, click **Control Word Trigger** to set Siemens PLC to send Acyclic Write Command to MGate 5102-PBM-PN.

D. Log in to the MGate 5102-PBM-PN web console. Click **System Management** → **Maintenance** → **PROFIBUS Control**, the status for the operation mode is **Operate**.

5.1.2. Read Status Word Test

After Test A (**Write Control Word Test**), click **Status Word Trigger** to set Siemens PLC to send Acyclic Read Command to MGate 5102-PBM-PN. The value for the Status Word input box value is updated to 3.
5.1.3. Read Communication List Test

After Test B (Read Status Word Test), click Communication List Trigger to set Siemens PLC to send Acyclic Read Command to MGate 5102-PBM-PN. The values for Slave 0~7 input boxes should be updated to 8 to indicate that MGate 5102-PBM-PN is exchanging datat (“Data_Exchange”) with PROFIBUS Slave (at address “3”).
5.2. Using the Variable Table

Open the VAT_1 variable table and click the Monitor icon to connect PLC to the monitor variables.

### 5.2.1. Write Control Word Test

A. Log in to the MGate 5102-PBM-PN web console. Click System Management → Maintenance → PROFIBUS Control and change the operation mode to Stop.
B. In the **VAT_1** variable table, set **DB1.DBW 0** to **W#16#0003** and click the **Active Modify Value** icon. The value for the **DB1.DBW 0** status value should be updated to **W#16#0003**.

C. Set **M 0.0** to **true** and click the **Active Modify Value** icon. This sets Siemens PLC to send Acyclic Write Command to MGate 5102-PBM-PN.

D. Log in to the MGate 5102-PBM-PN web console. Click **System Management → Maintenance → PROFIBUS Control** and the status for the operation mode becomes **Operate**.
5.2.2. Read Status Word Test

After Test A (Write Control Word Test), set M 1.0 to true; then, click the Active Modify Value icon. This sets Siemens PLC to send Acyclic Read Command to MGate 5102-PBM-PN. The status value of DB2.DBW 0 should be updated to W#16#0003.

5.2.3. Read Communication List Test

After Test B, set M 2.0 to true; then, click the Active Modify Value icon. This sets Siemens PLC to send Acyclic Read Command to MGate 5102-PBM-PN. The status value of DB2.DBB 2 should be updated to B#16#08 to indicate that MGate 5102-PBM-PN is exchanging data (“Data_Exchange”) with PROFIBUS Slave at address 3.