The software described in this manual is furnished under a license agreement and may be used only in accordance with the terms of that agreement.

Copyright Notice

© 2018 Moxa Inc. All rights reserved.

Trademarks

The MOXA logo is a registered trademark of Moxa Inc.

All other trademarks or registered marks in this manual belong to their respective manufacturers.

Disclaimer

Information in this document is subject to change without notice and does not represent a commitment on the part of Moxa.

Moxa provides this document as is, without warranty of any kind, either expressed or implied, including, but not limited to, its particular purpose. Moxa reserves the right to make improvements and/or changes to this manual, or to the products and/or the programs described in this manual, at any time.

Information provided in this manual is intended to be accurate and reliable. However, Moxa assumes no responsibility for its use, or for any infringements on the rights of third parties that may result from its use.

This product might include unintentional technical or typographical errors. Changes are periodically made to the information herein to correct such errors, and these changes are incorporated into new editions of the publication.

Technical Support Contact Information

www.moxa.com/support

<table>
<thead>
<tr>
<th>Moxa Americas</th>
<th>Moxa China (Shanghai office)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toll-free: 1-888-669-2872</td>
<td>Toll-free: 800-820-5036</td>
</tr>
<tr>
<td>Tel: +1-714-528-6777</td>
<td>Tel: +86-21-5258-9955</td>
</tr>
<tr>
<td>Fax: +1-714-528-6778</td>
<td>Fax: +86-21-5258-5505</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Moxa Europe</th>
<th>Moxa Asia-Pacific</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tel: +49-89-3 70 03 99-0</td>
<td>Tel: +886-2-8919-1230</td>
</tr>
<tr>
<td>Fax: +49-89-3 70 03 99-99</td>
<td>Fax: +886-2-8919-1231</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Moxa India</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tel: +91-80-4172-9088</td>
</tr>
<tr>
<td>Fax: +91-80-4132-1045</td>
</tr>
</tbody>
</table>
# Table of Contents

1. **Introduction** ........................................................................................................................................... 1-1  
   Overview .................................................................................................................................................. 1-2  
   System Requirements ............................................................................................................................. 1-2  
   Specifications ..................................................................................................................................... 1-2  

2. **Getting Started** ................................................................................................................................. 2-1  
   Installing MX-AOPC UA Server ................................................................................................................. 2-2  
   Configuring Active Tags ......................................................................................................................... 2-2  
   Opening the Configuration Console ......................................................................................................... 2-2  
   Configuring Server Settings ................................................................................................................... 2-4  
   Configuring Devices and Tags .................................................................................................................. 2-5  
   Adding a Modbus Device ....................................................................................................................... 2-5  
   Creating Modbus Tags ............................................................................................................................ 2-7  
   Updating Configurations to the Server .................................................................................................... 2-8  
   Using the Viewer to Check Tag Values .................................................................................................... 2-8  
   Configuring OPC UA Settings ................................................................................................................ 2-9  

3. **Configuration Console** ....................................................................................................................... 3-1  
   Main Screen Overview .............................................................................................................................. 3-2  
   Menu Items ........................................................................................................................................ 3-3  
   File ..................................................................................................................................................... 3-3  
   Edit ..................................................................................................................................................... 3-5  
   View .................................................................................................................................................. 3-5  
   Tools ................................................................................................................................................. 3-6  
   RunTime .......................................................................................................................................... 3-12  
   Help ................................................................................................................................................ 3-12  

4. **Device Management** ............................................................................................................................ 4-1  
   Device Group ..................................................................................................................................... 4-2  
   Adding a Device Group ........................................................................................................................... 4-2  
   Editing a Device Group ............................................................................................................................ 4-3  
   Deleting a Device Group ........................................................................................................................ 4-4  
   Active Devices .................................................................................................................................... 4-4  
   Deleting an Active Device from the Active Device Group List ............................................................ 4-4  
   Modbus Devices ................................................................................................................................ 4-5  
   Adding a Modbus Device to a Device Group ....................................................................................... 4-5  
   Importing a List of Modbus Devices into Device Groups ................................................................... 4-7  
   Editing a Modbus Device ........................................................................................................................ 4-7  
   Deleting a Modbus Device ..................................................................................................................... 4-8  
   Moving a Modbus Device to a Different Device Group ....................................................................... 4-8  

5. **Tag Management** ............................................................................................................................... 5-1  
   Tag Groups ...................................................................................................................................... 5-2  
   Adding a Tag Group to a Device ............................................................................................................ 5-2  
   Editing a Tag Group .............................................................................................................................. 5-3  
   Cutting a Tag Group .............................................................................................................................. 5-3  
   Copying a Tag Group ............................................................................................................................. 5-4  
   Pasting a Tag Group ............................................................................................................................. 5-4  
   Deleting a Tag Group ............................................................................................................................ 5-5  
   Modbus Tags .................................................................................................................................... 5-5  
   Adding a Modbus Tag to a Tag Group ................................................................................................... 5-5  
   Importing a List of Modbus Tags into a Modbus Device .................................................................. 5-7  
   Editing a Modbus Tag .......................................................................................................................... 5-7  
   Deleting a Modbus Tag ........................................................................................................................ 5-7  

6. **License Registration and Activation** ................................................................................................. 6-1  

A. **Appendix** .......................................................................................................................................... A-1  
   Port Usage ....................................................................................................................................... A-1  
   Configuring DCOM Settings ............................................................................................................... A-1
The following topics are covered in this chapter:

- Overview
- System Requirements
- Specifications
Overview

Moxa has pioneered the concept of “active type” OPC software in the automation industry. The patented MX-AOPC UA Server offers both polling (Modbus protocol) and non-polling (Moxa AOPC protocol) architectures alongside the standard OPC UA protocol, giving users the alternative of pull or push-based communication from Moxa’s devices. OPC UA (Unified Architecture), which features more secure and reliable data communication between OPC servers and clients, is the next generation OPC standard (IEC 62541). By using Moxa’s MX-AOPC UA Server, users can enjoy more secure and reliable data exchange and control.

The MX-AOPC UA Server includes:

- **Server Runtime Service**: Starts as a service by default after installation.
- **Configuration Console**: An offline configuration tool for configuring server settings.
- **Viewer**: An OPC client that allows developers, testers, and integrators to easily view tag values and test MX-AOPC UA Server and connections.

System Requirements

**Hardware Requirements**
- CPU: Intel Pentium 4 or above
- RAM: 512 MB (1024 MB recommended)
- Communication Interface: Ethernet or serial

**Software Requirements**
- Microsoft .NET Framework: v3.5 Service Pack 1
- Editor (optional): Microsoft Office 2003 Excel or later

Specifications

**OPC Server Specifications**
- OPC Unified Architecture: 1.02
- OPC Data Access: 1.0a, 2.0, 2.05a, 3.0
- Device Protocols: Moxa AOPC, Modbus/TCP (master), Modbus/RTU (master)

**Products that Support AOPC Protocol**

Note: Please check Moxa’s website for the most up-to-date list of supported products.

**Fully Supported OPC UA Server Profiles**
- Standard UA Server Profile
- Core Server Facet
- **User Token - User Name Password Server Facet**
- **SecurityPolicy - None**
- Data Access Server Facet
- UA-TCP UA-SC UA Binary
- **User Token - X509 Certificate Server Facet**
- **SecurityPolicy - Basic128Rsa15**
- **SecurityPolicy - None**
The following topics are covered in this chapter:

- Installing MX-AOPC UA Server
- Configuring Active Tags
- Opening the Configuration Console
- Configuring Server Settings
- Configuring Devices and Tags
  - Adding a Modbus Device
  - Creating Modbus Tags
- Updating Configurations to the Server
- Using the Viewer to Check Tag Values
- Configuring OPC UA Settings
Installing MX-AOPC UA Server

MX-AOPC UA Server can be downloaded from the Moxa website at [www.moxa.com](http://www.moxa.com).

After downloading the file, unzip it and run setup.exe. The installation program will guide you through the MX-AOPC UA Server installation process.

**NOTE**

Microsoft .NET Framework v3.5 Service Pack 1 is required before installing MX-AOPC UA Server. After the .NET Framework is installed, restart your computer and run setup.exe again to install MX-AOPC UA Server.

Configuring Active Tags

MX-AOPC UA Server will automatically receive active tags from Moxa’s remote devices through the Moxa AOPC protocol once the tags are created. Refer to the device’s user’s manual to learn how to use the device’s configuration utility to create active tags.

Opening the Configuration Console

Open MX-AOPC UA Server’s configuration console from the Windows Start menu: **Start → All Programs → MOXA → IO Server → MX-AOPC UA Suite → MX-AOPC UA Server.**

Select main network adapter the first time you open the configuration console.

The configuration console is an offline configuration tool for configuring Server Runtime settings. When the configuration console is launched, it will automatically get the latest configurations from the Server Runtime. If any active tag is received, the device will be listed in the **Active Device List.** To manually get the latest configurations from the Server Runtime, click the **Get Configuration from Server** icon on the MX-AOPC UA Server menu bar. To manually update the settings to the Server Runtime, click the **Update Configuration to Server** icon on the menu bar.
NOTE The first time you use MX-AOPC UA Server, we recommend turning off, or adding rules to, the Windows Firewall and then checking to see if MX-AOPC UA Server is able to receive active tags. If it can, turn the Windows Firewall back on and check it again. If MX-AOPC UA Server does not receive any active tags after you turn on the Windows Firewall, add aopcservice.exe in the Firewall Inbound Rules, and set it to Allow for Private, Public, and Domain network profiles.

NOTE Be sure to update the settings to the Server Runtime after changing the configuration. Otherwise, the Server Runtime will not reflect the configuration changes made using the configuration console.
Configuring Server Settings

Before configuring devices and tags, configure the server settings described below under the Tools menu.

- **Change Password**
  We strongly recommend changing the password the first time you use the Configuration Console. The default password is “moxa”, which is needed for verification when updating configurations to the Server Runtime or exporting the system log to a text file.

  **NOTE** When connecting an OPC UA client to MX-AOPC UA Server, use account name “admin” (the account name cannot be changed) and whatever the password is. The password is the same as the system password, which can be updated using Tools → Change Password.

- **Serial Port Settings**
  Configure the PC’s Serial Port Settings if a serial device is connected to MX-AOPC UA Server.
• **AOPC Settings**

Configure **AOPC Settings** if a Moxa device updates Active Tags to MX-AOPC UA Server.

![AOPC Settings Configuration](image)

### Configuring Devices and Tags

#### Adding a Modbus Device

1. Click the **Modbus Device Group List** to select it and then click the **New Device Group** icon and type in the name of the device group.

![Device Group List Configuration](image)
2. Click the **New Device** icon and then configure the device properties.

3. Click the device group you just created to display a list of the devices in this group.
Creating Modbus Tags

1. Click the device name to select it and then click the **New Tag Group** icon and type in the name of the tag group.

2. Click the **New Tag** icon and then configure the tag properties.
3. The tag will be listed in the tag group.

### Updating Configurations to the Server

When you finish updating the configuration, click the **Update Configuration to Server** icon to update the configuration to the Server Runtime. When the **Verify Password** window pops up, enter the correct password and then click **OK** to activate the changes.

### Using the Viewer to Check Tag Values

After completely updating the Server Runtime settings, click the **Viewer** icon to open the viewer to check that the tag value is correct.
The device tree in the left panel should be the same as the tree displayed by the configuration console. Click a tag group name to display the group’s tag values in the right panel.

Configuring OPC UA Settings

You should configure OPC UA settings before connecting an OPC UA client to MX-AOPC UA Server. To access OPC UA Settings options, click Tools → OPC UA Settings. Instructions for each option are given below.
• **Server Endpoints Settings**

“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with MX-AOPC UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type protocols.

To add a new interface to the list, select the appropriate network interface in the **Network Interface** drop-down box and type the port number for the URL in the **Port Number** input box. Click **Add** to add this new server endpoint to the list.

![Server Endpoints Settings](image)

• **Security Policy**

The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security options that can be selected are **None**, **Basic128Rsa15: Sign**, or **Basic128Rsa15: Sign and Encrypt**. If Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both of these options are selected, you will need to configure **Certificates Management** settings (see below).

![Security Policy Setting](image)

**NOTE**

The default Account and Password for connecting an OPC UA client to the server are:
- Account: admin
- Password: moxa

The account name cannot be changed. To change the password, click **Tools → Change Password**.
• **Certificates Management**

If the security policy is set to Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both, importing an OPC UA client’s CA (Certificate Authority) file into MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the **Trust Clients** tab, click **Import**, and select the client’s CA file to import it into MX-AOPC UA Server.

Click the **Instance Certificates** tab and click **Export Server Certificate** to export MX-AOPC UA Server’s CA file to OPC UA Clients.

Click the **Update Configuration to Server** icon to enable any changes that have been made to the OPC UA configuration.

**NOTE**  
After reissuing certificates or re-installing MX-AOPC UA Server, you will need to once again export the Server Certificate to OPC UA clients.
The following topics are covered in this chapter:

- **Main Screen Overview**
- **Menu Items**
  - File
  - Edit
  - View
  - Tools
  - Runtime
  - Help
Main Screen Overview

MX-AOPC UA Server's configuration console displays the mapped I/O device with the settings of every I/O tag. It also shows the Server Runtime status and number of OPC clients.

<table>
<thead>
<tr>
<th>No.</th>
<th>Zone</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Software Title</td>
<td>Displays the name of the software: MX-AOPC UA Server</td>
</tr>
<tr>
<td>2</td>
<td>Menu</td>
<td>All configuration functions</td>
</tr>
<tr>
<td>3</td>
<td>Quick Launch Bar</td>
<td>Frequently used icons</td>
</tr>
<tr>
<td>4</td>
<td>Device View</td>
<td>All devices and tags</td>
</tr>
<tr>
<td>5</td>
<td>Detailed View</td>
<td>Detailed settings of the devices and tags</td>
</tr>
<tr>
<td>6</td>
<td>Log View</td>
<td>Server Runtime logs</td>
</tr>
<tr>
<td>7</td>
<td>Server Runtime Status</td>
<td>Shows if the Server Runtime Service is <strong>Running</strong> or <strong>Stopped</strong></td>
</tr>
<tr>
<td>8</td>
<td>Server Time</td>
<td>Displays the server time (same as the PC's time)</td>
</tr>
<tr>
<td>9</td>
<td>Numbers of Device</td>
<td>Displays the number of devices listed in Device View</td>
</tr>
<tr>
<td>10</td>
<td>Numbers of OPC Client</td>
<td>Displays the number of OPC clients connected to MX-AOPC UA Server</td>
</tr>
</tbody>
</table>
Menu Items

All operations can be accessed from the following Menu items.

File

Use the **File** menu to manage project files, device tags, and server configuration.

- **New**: Create a new project file.
- **Open**: Open an existing project file.
- **Save**: Save the current project.
- **Save As**: Save the current project file as another project with a different filename.
- **Import**:
  - Ethernet Modbus Device (.csv): Import Ethernet Modbus devices into device groups from a csv file.

<table>
<thead>
<tr>
<th>Item</th>
<th>Format</th>
<th>Length</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>DeviceGroupName</td>
<td>0 to 9, A to Z, a to z, Symbols</td>
<td>30</td>
<td>&quot;.&quot; is not allowed.</td>
</tr>
<tr>
<td>DeviceName</td>
<td>0 to 9, A to Z, a to z, Symbols</td>
<td>30</td>
<td>&quot;.&quot; is not allowed.</td>
</tr>
<tr>
<td>Enable</td>
<td>0: disable; 1: enable</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>CommunicationPort</td>
<td>Network adapter name</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>DeviceID</td>
<td>1 to 247</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>IPAddress</td>
<td>xxx.xxx.xxx.xxx</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>Port</td>
<td>0 to 65535</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>ReconnectDelay(ms)</td>
<td>0 to 30000</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>ReconnectCycle</td>
<td>0 to 10</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>CycleDelay(sec)</td>
<td>0 to 86400</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>PollingTimeout(ms)</td>
<td>0 to 30000</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>PollingRetries</td>
<td>0 to 10</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>DelayBetweenPolls(ms)</td>
<td>100 to 360000; 0 disabled</td>
<td>-</td>
<td></td>
</tr>
</tbody>
</table>
Serial Modbus Device (.csv): Import Serial Modbus devices into device groups from a csv file.

<table>
<thead>
<tr>
<th>Item</th>
<th>Format</th>
<th>Length</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>DeviceGroupName</td>
<td>0 to 9, A to Z, a to z, Symbols</td>
<td>30</td>
<td>“.” is not allowed.</td>
</tr>
<tr>
<td>DeviceName</td>
<td>0 to 9, A to Z, a to z, Symbols</td>
<td>30</td>
<td>“.” is not allowed.</td>
</tr>
<tr>
<td>Enable</td>
<td>0: disable; 1: enable</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>CommunicationPort</td>
<td>Serial port name</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>DeviceID</td>
<td>1 to 247</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>ResponseTimeout(ms)</td>
<td>0 to 30000</td>
<td>-</td>
<td></td>
</tr>
</tbody>
</table>

Device Tags (.csv): Import device tags into a Modbus device from a csv file.

<table>
<thead>
<tr>
<th>Item</th>
<th>Format</th>
<th>Length</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>GroupName</td>
<td>0 to 9, A to Z, a to z, Symbols</td>
<td>30</td>
<td>“.” is not allowed.</td>
</tr>
<tr>
<td>TagName</td>
<td>0 to 9, A to Z, Symbols</td>
<td>30</td>
<td>“.” is not allowed.</td>
</tr>
<tr>
<td>FunctionCode</td>
<td>1 to 4</td>
<td>-</td>
<td>1: Read/Write Coils</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2: Read Discrete Inputs</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3: Read/Write Holding Registers</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>4: Read Input Registers</td>
</tr>
<tr>
<td>Address</td>
<td>0 to 65535</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>DataType</td>
<td>Boolean, Unsigned short integer, Unsigned integer, Float</td>
<td>-</td>
<td>Use Boolean with FunctionCode 1 or 2.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Use other DataTypes with FunctionCode 3 or 4.</td>
</tr>
<tr>
<td>Description</td>
<td>0 to 9, A to Z, a to z, Symbols</td>
<td>25</td>
<td></td>
</tr>
<tr>
<td>TagQuantity</td>
<td>1 to 2000 when function code is 1 or 2, 1 to 125 when function code is 3 or 4</td>
<td>TagQuantity</td>
<td></td>
</tr>
<tr>
<td>DataConversion</td>
<td>None</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;LoByte &amp; HiByte&quot; (if Unsigned Short Integer is defined)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;HiByte &amp; LoByte&quot; (if Unsigned Short Integer is defined)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;LoWord &amp; HiWord&quot; (if Unsigned Integer or Float is defined)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;HiWord &amp; LoWord&quot; (if Unsigned Integer or Float is defined)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>StartNumber</td>
<td>0 to 99</td>
<td>-</td>
<td></td>
</tr>
</tbody>
</table>

Export:
- Ethernet Modbus Device (.csv): Export Ethernet Modbus devices from device groups to a csv file.
- Serial Modbus Device (.csv): Export Serial Modbus devices from device groups to a csv file.
- Device Tags (.csv): Export device tags from a Modbus device to a csv file.

Get Configuration from Server: Get the latest configuration from the Server Runtime.

Update Configuration to Server: Update the configuration to the Server Runtime from the Configuration Console.

Previous saved files: Quickly open previously saved project files.

Exit: Close the Configuration Console.

NOTE Active Tags cannot be imported into an Active Device folder in the Configuration Console from a csv file, or vice versa. Active Tags are automatically created by a Moxa active tag device. Refer to the Specifications section for the Products that Support AOPC Protocol, and refer to the device’s user’s manual to see how to create active tags using the device’s configuration utility.

NOTE Execute the Export function to get a csv template.
Edit

Use the **Edit** menu to edit settings of devices and tags.

- **Cut**: Cut a tag group or selected tags.
- **Copy**: Copy a tag group or selected tags.
- **Paste**: Paste a cut or copied tag group into a device, or paste cut or copied tags into a tag group.
- **Delete**: Delete the selected device, a selected tag group, or selected tags.
- **Select All**: Select all tags in a tag group.
- **New Device Group**: Create a new device group.
- **New Device**: Create a new Modbus device.
- **New Tag Group**: Create a new tag group.
- **New Tag**: Create a new tag.
- **Properties**: Modify the settings of an existing device group, device, tag group, or tag.

**NOTE** The properties of an active device or active tag cannot be modified from the configuration console. Refer to the device’s user’s manual to see how to use the device’s configuration utility to change active device or active tag settings.

View

Use the **View** menu to change the display settings of the Device View panel.

- **Expand All Devices**: Expand all devices in the Device View panel.
- **Collapse All Devices:** Collapse all devices in the Device View panel.

**Tools**

Use the **Tools** menu to configure serial ports, OPC settings, system log, password, console environment settings, or to launch Viewer.
• Serial Port Settings

- Baud Rate: 300 to 921600 bps; default: 115200 bps
- Flow Control: None, RTS/CTS, or XON/XOFF; default: None
- Data Bits: 5, 6, 7, or 8; default: 8
- Stop Bits: 1 or 2; default: 1
- Parity: Even, Odd, or None; default: None

• AOPC Settings

- Default Network Interface: Select a network interface that remote devices can use to connect to MX-AOPC UA Server.
- Active Tag Listen Port: The preferred TCP socket port for receiving active tags from remote devices (default: 9900).
- Command Timeout: The socket timeout interval (Port: 9500 and 9900) for controlling output channels on remote devices: 0 to 60; default: 30 sec.
- Heartbeat Tolerance: An additional timeout interval to wait for a heartbeat signal from remote devices: 0 to 60; default: 30 sec.

• DCOM Configuration: Configure DCOM settings for your security policy. Refer to Appendix A for details.
MX-AOPC UA Server Configuration Console

- **OPC UA Settings**

  ![MX-AOPC UA Server Configuration Console](image)

  ➤ **Server Endpoints Settings:**

  "Server Endpoints Settings" are a list of interfaces that UA clients can use to communicate with MX-AOPC UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type protocols.

  To add a new interface to the list, select the appropriate network interface in the **Network Interface** drop-down box and type the port number for the URL in the **Port Number** (default: 53192) input box. Click **Add** to add this new server endpoint to the list.
MX-AOPC UA Server

Security Policy

The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security options that can be selected are None, Basic128Rsa15: Sign, or Basic128Rsa15: Sign and Encrypt. If Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both of these options are selected, you will need to configure Certificates Management settings (see below).

![Security Policy Setting](image)

NOTE

The default Account and Password for connecting an OPC UA client to the server are:

- Account: admin
- Password: moxa

The account name cannot be changed. To change the password, click Tools → Change Password.

Certificates Management

If the security policy is set to Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, or both, importing an OPC UA client’s CA (Certificate Authority) file into MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC UA Server.

![Certificates Management](image)
Click the **Instance Certificates** tab and click **Export Server Certificate** to export MX-AOPC UA Server’s CA file to OPC UA Clients.

**Certificates Management**

![Certificate Management](image)

Certificate MX-AOPC UA Server is from 2014/10/28 09:42:23 AM to 2015/10/2 09:42:23 AM

Click the **Update Configuration to Server** icon to enable any changes that have been made to the OPC UA configuration.

**NOTE** After reissuing certificates or re-installing MX-AOPC UA Server, you will need to once again export the Server Certificate to OPC UA clients.

- **Viewer**: Open the viewer to check that the tag value is correct.
- **System Log**

![System Log](image)
- **Save to Text File:** Save MX-AOPC UA Server’s system log to a text file. You will be required to enter a password (default password: moxa).

![Verify Password](image1)

- **Reset System Log:** Reset MX-AOPC UA Server’s system log. You will be required to enter a password (default password: moxa).

![Active OPC](image2)

- **System Log Settings:** Defines the maximum number of records that can be saved in the MX-AOPC UA Server’s system log: 1 to 30000; default: 30000.

![System Log Settings](image3)

- **Change Password:** Change the MX-AOPC UA Server’s system password. The password is required when updating configurations to System Runtime, saving system logs to a text file, or resetting system log. Length: 4 to 128; acceptable characters: A to Z, a to z, 0 to 9, Symbols; default: moxa.

![Change Password](image4)
• **Options:** Configure environment settings for the server’s configuration console.

![Options window]

**NOTE** If *Automatically save configuration every xx min(s)* is enabled, the configuration file will be automatically saved only when a file name is defined. Be sure to save your configuration file after creating a new project file.

### Runtime

Use the **Runtime** menu to Start, Stop, or Reinitialize Server Runtime Service.

![Runtime menu]

### Help

Use the **Help** menu to launch the server’s help documentation, to check the server’s license status, to add a license file, or check server version.

- **Server Help:** Launch MX-AOPC UA Server’s help documentation.
- **Licensing**

  - **License Info:** Displays the server's User Code, License Status, and the Time Remaining on the license. Refer to **Chapter 6: License Registration and Activation** to learn how to activate the license.

    ![License Info Image](image)

  - **Add License File:** Import a license file after completing the license registration process. Refer to **Chapter 6: License Registration and Activation** to learn how to activate the license.

  - **Deactivate License:** Deactivate the current paid license version and load factory default settings. Note that when you deactivate the license, your license file and runtime configurations will be deleted. Please backup your runtime configurations before executing a license deactivation procedure.

- **About:** Displays MX-AOPC UA Server's version number and build number.
The following topics are covered in this chapter:

- **Device Group**
  - Adding a Device Group
  - Editing a Device Group
  - Deleting a Device Group

- **Active Devices**
  - Deleting an Active Device from the Active Device Group List

- **Modbus Devices**
  - Adding a Modbus Device to a Device Group
  - Importing a List of Modbus Devices into Device Groups
  - Editing a Modbus Device
  - Deleting a Modbus Device
  - Moving a Modbus Device to a Different Device Group
Device Group

In this section we explain how to use the configuration console to add, edit, and delete device groups.

MX-AOPC UA Server’s design logic is user-application oriented. As seen below, device groups can be created based on application, such as SiteA or SiteB.

Adding a Device Group

1. Right click Modbus Device Group List and then click New Device Group in the popup menu, or click Modbus Device Group List to select it, and then click the New Device Group icon on the Quick Launch toolbar.
2. Type in the name of the device group (max. length = 30 characters; “.” is not allowed), and then click **OK**.

![Device Group Property](image)

3. The new device group will be added to the **Modbus Device Group List**.

![Modbus Device Group List](image)

**Editing a Device Group**

Right click the device group you would like to edit and then click **Properties** in the popup menu, or click the device group to select it and then click the **Properties** icon on the Quick Launch toolbar to open the properties window.

![Properties Icon](image)
Deleting a Device Group

Right click the device group you would like to delete and then click **Delete** in the popup menu, or click the device group to select it and then click the **Delete** icon from the Quick Launch toolbar.

![Deleting a Device Group](image)

Active Devices

In this section we explain how to use the configuration console to delete active devices.

MX-AOPC UA Server will automatically receive the registration from a Moxa active device located at a remote site. Refer to the Moxa I/O device’s user’s manual to learn how to use the device’s configuration utility to create active tags.

Deleting an Active Device from the Active Device Group List

Right click the active device you would like to delete and then click **Delete** in the popup menu, or click the active device to select it and then click the **Delete** icon from the Quick Launch toolbar.

![Deleting an Active Device](image)

**NOTE**

After an active-device name is changed through the web console or configuration utility, delete the active device on the MX-AOPC UA Server and execute "Update Configuration to Server." The change will take effect the next time the device creates active tags to the MX-AOPC UA Server.
Modbus Devices

In this section we explain how to use the configuration console to add, edit, delete, and move Modbus devices.

Adding a Modbus Device to a Device Group

Right click the device group you would like to add a new Modbus device to and then click New Device in the popup menu. You may instead click the device group to select it and then click the New Device icon on the Quick Launch toolbar.

Ethernet Communication Port

If an Ethernet communication port is selected, the Device Property configuration window will appear as shown below:

- **Device Name**: Name of the Modbus device (max. length = 30; "." is not allowed).
- **Enable Data Collection**: Enable or disable data collection for this Modbus device.
- **Communication Port**: Select the communication interface of this Modbus device.
- **Device ID**: The device ID of this Modbus device (options: 1 to 247).
MX-AOPC UA Server

Device Management

- **IP Address**: The IP Address of this Modbus device.
- **Port**: The TCP port of this Modbus device (options: 0 to 65535).
- **Delay between Polling**: The delay time after the server polls Modbus register(s) of this device (options: ms, 100 to 3600000; 0 disabled).
- **Reconnect Delay**: The delay time after the server tries to reconnect this Modbus device (options: 0 to 30000; default: 3000).
- **Reconnect Cycles**: The maximum number of reconnect cycles (options: 0 to 10; default: 3).
- **Cycle Delay**: The delay time after reaching the maximum number of reconnect cycles (options: 0 to 86400; default: 3).
- **Polling Timeout**: The timeout value when the server polls data from this Modbus device (options: 0 to 30000; default: 3000).
- **Polling Retries**: The maximum number of retries after a polling timeout occurs (options: 0 to 10; default: 3).

### Serial Communication Port

If a serial communication port is selected, the **Device Property** configuration window will appear as shown below:

![Device Property Configuration Window](image)

The following configuration items only appear when a serial communication port is selected.

- **Response Timeout**: The timeout value when the server polls the data of this Modbus device (options: 0 to 30000; default: 3000).
- **Polling Delay**: The delay time after a polling timeout occurs (0 to 60000; default: 10).
The newly created device group will now be shown as belonging to this group.

### Importing a List of Modbus Devices into Device Groups

Right click the Modbus Device Group List and then click Ethernet Modbus Device (.csv) or Serial Modbus Device (.csv) in the popup menu to import a list of Modbus devices into device groups. Select a csv file on your PC to import the devices listed in the csv file into the Device Groups. Refer to Chapter 3: Configuration Console → Menu Items → File for detailed csv file formats.

### Editing a Modbus Device

Right click the Modbus device you would like to edit and then click Properties... in the popup menu, or click the Modbus device to select it and then click the Properties icon in the Quick Launch toolbar to open the properties configuration window.

**NOTE** You are not allowed to cut, copy, or paste a Modbus device.
Deleting a Modbus Device

Right click the Modbus device and then click **Delete** in the popup menu, or click the Modbus device to select it and then click the **Delete** icon in the Quick Launch toolbar.

Moving a Modbus Device to a Different Device Group

1. Right click the Modbus device and then click the target device group in the popup menu.
2. The Modbus device will be moved to the target device group.
The following topics are covered in this chapter:

- **Tag Groups**
  - Adding a Tag Group to a Device
  - Editing a Tag Group
  - Cutting a Tag Group
  - Copying a Tag Group
  - Pasting a Tag Group
  - Deleting a Tag Group

- **Modbus Tags**
  - Adding a Modbus Tag to a Tag Group
  - Importing a List of Modbus Tags into a Modbus Device
  - Editing a Modbus Tag
  - Deleting a Modbus Tag
Tag Groups

In this section we explain how to use the configuration console to add, edit, cut, copy, paste, and delete tag groups.

Adding a Tag Group to a Device

1. Right click the device that the tag group will be added to and then click **New Tag Group** in the popup menu, or click the device to select it and then click the **New Tag Group** icon on the Quick Launch toolbar.

2. Type in the name of the tag group (max. length = 30 characters; "." is not allowed) and then click **OK**.

3. The new tag group will be added to the device.
Editing a Tag Group

Right click the tag group and then click **Properties** in the popup menu, or click the tag group to select it and then click the **Properties** icon on the Quick Launch toolbar.

![Editing a Tag Group](image1)

Cutting a Tag Group

Right click the tag group and click **Cut** in the popup menu, or click the tag group to select it and then click the **Cut** icon on the Quick Launch toolbar.

![Cutting a Tag Group](image2)
Copying a Tag Group

Right click the tag group and then click **Copy** in the popup menu, or click the tag group to select it and then click the **Copy** icon on the Quick Launch toolbar.

Pasting a Tag Group

Right click the Tag Group and then click **Paste** in the popup menu, or click the tag group to select it and then click the **Paste** icon on the Quick Launch toolbar.
Deleting a Tag Group

Right click the tag group and then click Delete in the popup menu, or click the tag group to select it and then click the Delete icon on the Quick Launch toolbar.

Modbus Tags

In this section we explain how to use the configuration console to add, edit, delete, and move a Modbus tag.

Adding a Modbus Tag to a Tag Group

1. Right click the tag group that the Modbus tag will be added to and then click New Tag in the popup menu, or click the tag group to select it and then click the New Tag icon on the Quick Launch toolbar.
2. Edit the items in the **Tag Property** window as needed.

![Tag Property Window]

**Function Code:** Select the function code for this Modbus tag (options: 01: Read/Write Coils; 02: Read Discrete Inputs; 03: Read/Write Holding Registers; 04: Read Input Registers).

**Address:** Show Read/Write or Read-only attribute of this tag(s).

**Tag Name:** The name of the Modbus tag (max. length = 30; "." is not allowed).

**Description:** Description of this Modbus tag (max. length = 25).

**Start Address:** Define the start address of this Modbus tag (0 to 65535).

**Coil Length / Register Length:** Define the length of the coil (1 to 2000) or the register (1 to 125).

**Data Type:** Selecting the data type of this Modbus tag (options: Boolean; Unsigned short integer; Unsigned integer; Float).

**Start Number:** Define the start number of the continuous coils or registers. The continuous coils or registers will be divided into different tags with unique name based on this number definition.

**Data Conversion:** Define the sequence of the High/Low Bytes or Words for the register(s).

**Tag Quantity:** Show the quantity of the tag(s).

3. Click the tag group to verify that the Modbus tag was added to this group.
Importing a List of Modbus Tags into a Modbus Device

To import a list of Modbus tags into a Modbus device, right click the Modbus device and then click **Import Device Tags (.csv)** in the popup menu. Select a csv file on your PC to import the tags listed in the csv file into the Modbus device. Refer to **Chapter 3: Configuration Console → Menu Items → File** for detailed csv file formats.

Editing a Modbus Tag

Click the Modbus tag to select it and then click the **Properties** icon on the Quick Launch toolbar.

Deleting a Modbus Tag

Click the Modbus tag to select it and then click the **Delete** icon on the Quick Launch toolbar.
License Registration and Activation

Three versions of MX-AOPC UA Server are available. The trial version, which supports up to 30 connected devices, can be installed and used for 30 days without registration. To use the free and paid versions you must submit a license registration. Both free and paid versions can be used indefinitely, but the free version only supports up to 30 connected devices. The three versions are summarized in the following table:

<table>
<thead>
<tr>
<th>Version</th>
<th>Connected Devices</th>
<th>Run Time</th>
<th>License File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trial</td>
<td>Up to 30</td>
<td>30 days</td>
<td>Not Required</td>
</tr>
<tr>
<td>Free</td>
<td>Up to 30</td>
<td>Unlimited</td>
<td>Required</td>
</tr>
<tr>
<td>Paid</td>
<td>Unlimited</td>
<td>Unlimited</td>
<td>Required</td>
</tr>
</tbody>
</table>

Take the following steps to register a license.

**Step 1:** Get the PC User Code from the MX-AOPC UA server’s configuration console by clicking Help ➔ License. For the paid version, you will need to purchase a registration code from your Moxa distributor. The Registration Code can be found on the product label.

**Step 2:** Go to Moxa’s Software Licensing website (http://license.moxa.com) and log in with your Moxa account and password, or apply for an account if this is your first visit to the site.

**Step 3:** On the Software Licensing website, navigate to Activate Your Software ➔ Software Package ➔ MX-AOPC UA Server. Select Free Version and enter the User Code, or select Paid Version and enter both the User Code and Registration Code.
Step 4: Download the license file to a folder on your PC and unzip it.

Step 5: From MX-AOPC UA server’s configuration console, click Help → Licensing → Add License File to add the license file (.lic) to MX-AOPC UA Server.

Step 6: After license activation is complete, go to Help → License Info to check the current license status.
Port Usage

<table>
<thead>
<tr>
<th>Port</th>
<th>Type</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>502</td>
<td>TCP</td>
<td>Modbus Communication</td>
</tr>
<tr>
<td>53192</td>
<td>TCP</td>
<td>Default UA Server Endpoint</td>
</tr>
<tr>
<td>9500</td>
<td>TCP</td>
<td>Moxa AOPC protocol</td>
</tr>
<tr>
<td>9900</td>
<td>TCP</td>
<td>Moxa AOPC protocol</td>
</tr>
</tbody>
</table>

Configuring DCOM Settings

If the OPC client only supports the OPC Data Access (DA) standard, you will need to configure DCOM settings. Before launching MX-AOPC UA Server, configure the DCOM settings for your security policy.

NOTE
If the OPC Client and Server software are installed on different servers, the DCOM, WORKGROUP, System Account, and Password settings should be the same.

1. Go to the START menu and type `dcomcnfg` to activate the Component Services dialog box.
2. Right click My Computer under Console Root → Component Services → Computers, and click Properties to open the My Computer Properties dialog box.

3. Click the COM Security tab and edit who is allowed by default to access, launch, or activate the applications or objects.
4. Add **Everyone**, **INTERACTIVE**, **NETWORK**, and **SYSTEM**, and set **Allow** permission to all of these groups.

![Access Permission](image1)

![Launch and Activation Permission](image2)
5. Click the **Default Properties** tab and check if the settings are the same as shown in the screenshot below.

![Default Properties Tab Screenshot](image1)

6. Click **Yes** when the following warning message appears.

![DCOM Machine wide settings](image2)
7. Go back to the Component Services dialog box, and right click **MOXA_ACTIVE_OPC_SERVER** under Console Root → Component Services → Computers → My Computer → DCOM Config, and then click Properties.

8. Click the General tab, and set the Authentication Level to Connect.
9. Click the **Security** tab. You may either apply the default settings of Access, Launch, and Activation Permissions to the MX-AOPC UA Server or customize the permission settings. If you would like to customize the settings, make sure that **Everyone**, **INTERACTIVE**, **NETWORK**, and **SYSTEM** are added, and the permission for these groups is set to **Allow**.
10. Click the **Identity** tab and make sure **The system account** is selected. Now DCOM is ready to accept all incoming connections.