Product support

Security Advisories

SUMMARY

AWK-3131A Series Wireless AP/Bridge/Client Vulnerability

  • Version: 1.0
  • Release Date: Apr 16, 2018
  • Reference:

A product vulnerability was identified in Moxa’s AWK-3131A Series Wireless AP/bridge/client. In response to this, Moxa has developed related solution to address these vulnerability.

The identified vulnerability type and potential impact are shown below:

Item Vulnerability Type Impact
1 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') Attackers could perform unauthorized commands, which could then be used to disable the software, or read and modify data for which the attacker should not have permission to access.
AFFECTED PRODUCTS AND SOLUTIONS

Affected Products

The affected products and firmware versions are shown below.

Product Series Affected Version
AWK 3131A Series Firmware Version 1.9 or prior

 

Solutions

Moxa has developed an appropriate solution to address the vulnerability. The solutions for affected products are shown below.

Product Series Solutions
AWK 3131A Series Please download the new firmware/software here.

 

Revision History

Version Description Release Date
1.0 First Release Apr 16, 2018

Relevant Products

AWK-3131A Series ·

  •   Print this page
  • You can manage and share your saved list in My Moxa
Let’s Get That Fixed

If you are concerned about a potential cybersecurity vulnerability, please contact us and one of technical support staff will get in touch with you.

Report a Vulnerability
Added To Bag