As of June 15, 2022, this site no longer supports Internet Explorer. Please use another browser for the best experience on our site.

Product support

Security Advisories


SDS-3008 Series Multiple Vulnerabilities

SDS-3008 Series firmware version v2.2 and prior are affected by multiple vulnerabilities in the old version of jQuery. These vulnerabilities could put your security at risk in many ways, such as Cross-site Scripting (XSS) attacks and prototype pollution.

The identified vulnerability types and potential impacts are shown below:

Item Vulnerability Type Impact
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (CWE-79)
CVE-2015-9251, CVE-2020-11022, CVE-2020-11023 (jQuery)
An attacker can remotely insert HTML or JavaScript into the system via a web interface, causing text/javascript to be executed.
Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') (CWE-1321)
CVE-2019-11358 (jQuery)
An attacker can inject attributes that are used in other components to execute cross-site scripting (XSS) attacks.

Vulnerability Scoring Details 

Unauthenticated Remote Exploit


CVE-2019-11358 6.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N Yes
CVE-2020-11022 6.9 AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N Yes
CVE-2020-11023 6.9 AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N Yes

Affected Products:

The affected products and firmware versions are shown below.

Product Series Affected Versions
SDS-3008 Series Firmware version 2.2 and prior.



Moxa has developed appropriate solutions to address the vulnerabilities by updating the jQuery version and removing weak cipher suites. The solutions for affected products are shown below.

Product Series Solutions
SDS-3008 Series Please contact Moxa Technical Support for the security patch.



Moxa recommends users follow CISA recommendations.

  • Reduce network exposure by ensuring that all control system devices and systems are not accessible from the Internet.
  • Place control system networks and remote devices behind firewalls, isolating them from business networks.
  • When remote access is necessary, employ secure methods such as Virtual Private Networks (VPNs). It is important to note that VPNs may have vulnerabilities and should be kept up to date with the latest available version. Remember that the security of a VPN depends on the security of its connected devices.


Products That Are Not Vulnerable:

Only the products listed in the Affected Products section of this advisory are known to be affected by these vulnerabilities. Moxa has confirmed that this vulnerability does not affect the following products:

  • TN-4500A Series, TN-5500A Series
  • TN-4900 Series
  • PT-G503 Series, PT-7728 Series, PT-7828 Series


Revision History:

1.0 First Release Jun. 19, 2024

Relevant Products

SDS-3008 Series ·

  •   Print this page
  • You can manage and share your saved list in My Moxa
Let’s get that fixed

If you are concerned about a potential cybersecurity vulnerability, please contact us and one of technical support staff will get in touch with you.

Report a Vulnerability
Added To Bag
You have some items waiting in your bag; click here to finish your quote!