Product support

Security Advisories

SUMMARY

EDS-405A Series Ethernet Switches Vulnerability

  • Version: V1.0
  • Release Date: Aug 09, 2021
  • Reference:
    • N/A

A product vulnerability was identified in Moxa’s EDS-405A Series. In response to this, Moxa has developed a related solution to address the vulnerability.

The identified vulnerability type and potential impacts are shown below:

Item Vulnerability Type Impact
1 Stack-based buffer overflow
  1. The attacker may execute arbitrary codes or target the device to cause it to go out of service.
  2. The password verification mechanism is vulnerable to buffer overflows and the attacker may use this vulnerability to cause denial-of-service.
AFFECTED PRODUCTS AND SOLUTIONS

Affected Products:

The affected products and firmware versions are shown below.

Product Series Affected Versions
EDS-405A Series Firmware Version 3.8 or lower

 

Solutions:

Moxa has developed appropriate solutions to address the vulnerabilities. The solutions for affected products are shown below.

Product Series Solutions
EDS-405A Series Please upgrade to firmware version 3.10 or higher. (Download Link)

Acknowledgment:

We would like to express our appreciation to Liu Jinyong from Industrial Control Security Laboratory of Qi An Xin Group Inc. for reporting the vulnerability, working with us to help enhance the security of our products, and helping us provide a better service to our customers.

Revision History:

VERSION DESCRIPTION RELEASE DATE
1.0 First Release Aug 09, 2021

Relevant Products

EDS-405A Series ·

  •   Print this page
  • You can manage and share your saved list in My Moxa
Let’s get that fixed

If you are concerned about a potential cybersecurity vulnerability, please contact us and one of technical support staff will get in touch with you.

Report a Vulnerability
Added To Bag
Feedback